Workshop on Map Analysis and Modeling — Exercises

Exercises for GIS Modeling Workshop

—Exercise #1 — Map Analysis Framework (MapCalc)

— Exercise #2 — Example of a Simple Erosion Potential Model (MapCalc)
— Exercise #3 — Reclassify and Overlay Techniques (MapCalc)

— Exercise #4 — Measuring Distance and Connectivity (MapCalc)

— Exercise #5 — Characterizing Spatial Neighborhoods (MapCalc)

— Exercise #6 — Surface Modeling (Surfer and MapCalc)

— Exercise #7 — Spatial Data Mining (MapCalc)

— Exercise #8 — Gaining GIS Modeling Experience (MapCalc)

—Optional Exercise — Data Exchange Procedures (MapCalc)

Installing MapCalc— The Workshop CD comes with a 14-day evaluation copy of the MapCalc Learner
software. To install MapCalc press Start> Run-> then browse to the ...\ Workshop\MapCalc\ folder on
the CD and select the mapcalclearner.exe file. Follow the onscreen installation instructions. It is
recommended that you accept the default specifications as the exercise write-ups assume this installation
location.

Accessing MapCalc— Once MapCalc is installed, copy the entire ...\ WorkshopData\ folder on the
Workshop CD to the C:\Program Files\Red Hen Systems\MapCalc\MapCalc Data\ folder on your
computer.

To access MapCalc press Start> Programs—> MapCalc—> MapCalc Learner. In the Quick Start box
select “Open existing map set” and browse to the ...\WorkshopData\ folder on your computer and click
on the appropriate ***.rgs database as instructed in the exercises (e.g., Exercise 1 uses Tutor25.rgs).

Uninstalling MapCalc— To uninstall MapCalc press Start> Control Panel-> Add or Remove
Programs-> and select MapCalc Learner to remove.

Exercise #1 — Map Analysis Framework (MapCalc)

Install MapCalc and access MapCalc by Start> Programs-> MapCalc Learner > MapCalc Learner and select
“Open existing map set” then browse to ...\WorkshopData\ and select Tutor25.rgs as the database.

X

Slowly move the cursor over the map and observe the map values associated with various locations. The
color levels identified in the map legend aggregate the elevation values into ten 200-foot contour intervals ranging
from 500 to 2500 feet.

Click on the Layer mesh button on the main tool bar. The grid configuration for the Tutor25 database is 25
columns by 25 rows (25 x 25= 625 grid cells). Each cell is 100 x 100 meters (10,000 square meters; one hectare;
2.54 acres). The maps in the database are hypothetical and the Latitude and Longitude coordinates for the project
area were arbitrarily assigned. The contour lines and interactive data labels for the Elevation map are interpolated
“on-the-fly” from the underlying grid data.

Click on the Use cells button. The display switches from “Lattice” to “Grid” display type with the contour color
codes assigned to entire cells.

Click on the Toggle 3D view button. The display switches to a “3-D Grid’ display type. The color-coding at the
top of each projected cell identifies the elevation value at that location.

Feve e o

KT
| The navigation tools enable you to zoom, pan and rotate a display.
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Click on the Zoom in button then click-and-drag a rectangular portion of the displayed map to enlarge that area.
Click on the Zoom out button then click-and-hold while sliding up and down to continuously rescale the display
when you release the mouse button.

Click on the Move button and click-and-hold to move the display to another part of the screen.

Click on the Rotate button then click-and-hold as you rotate the plot cube.

Click on the Reset view button to return to the default display settings.

ANANENEENEN

Click off the Use cells button to switch to a “3-D Lattice” display type, commonly called a “wireframe” display.
Note that the navigation tools operate in the same manner for both the grid and lattice display types.

r o
W"}_j’ Click off and on the Layer contoured and Layer contour lines buttons to turn off and on the contour-fill
colors and lines.

o Ef
Click off and on the Floor contours/lines and Ceiling contours/lines buttons and note the

changes in the 2-D projected planes in the plot cube.

Click on the word “Map” in the main menu, then select “Overlay” and choose the “Slope” map. The result is a
graphical overlay of the Slope map on the 3-D display of the Elevation map. Note that the areas classified as steep
(green tones) align with the steepest portions of the terrain surface.

Click on the Arrange windows buttons to view all of the open map windows in different arrangements.

Click on the Maximize button in the Slope map’s window to enlarge the display to fit the entire work area. For review,
repeat the display tools exercises you just completed using the elevation map on the Slope map.

Clicking on the word “Window” on the main menu produces a listing of open windows and window management
tools. Clicking on any of the open map windows listed will cause that map to be maximized in the work area.

ﬂ Click on the Layer Manager (View, Rename and Delete layers) button to pop-up a listing of the current maps in
the Tutor25 database. You can Rename and Delete existing maps. As new maps are created they are added to the
list. The View function opens a map in a new window. It is important to note that you can have multiple windows
open of the same map (Clone view). While this can cause some initial confusion, experienced MapCalc users find it
useful for positioning side-by-side views of the same data, such as a 2-D display and a 3-D plot. On the Main Menu,
click File-> Exit (no need to save your work).

EEEEIE =R
". =& A7 ES am = |“|Ke\ © 82| | additional demonstrations of basic grid-based data

handling including map display (Lattice and Grid) shading manager (# Ranges, Equal Ranges, Equal Count), data
types (Discrete and Continuous), data inspection/charting covered in the MapCalc Tutorials. On the special
workshop disk, see...

...\MapCalc\MapCalc_Tutorials\MapCalc_Tutorials.pdf

for a printable file containing this basic set of tutorials covering MapCalc operation and grid-based map analysis
fundamentals.
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Exercise #2 — Example of a Simple Erosion Potential Model (MapCalc)

Access MapCalc using the Tutor25.rgs database by selecting Start-> Programs-> MapCalc Learner-> MapCalc
Learner-> Open existing map set-> Tutor25.rgs by browsing to the ...\WorkshopData\ folder you copied from the
workshop CD.

Become familiar with the following simple model for estimating soil erosion potential...

Logical flowchart—

500 feet 0% 1 Gentle 11 Light/Gentle

5 — 5 —— 2 Moderate 5

2500 feet 65 % 3 Steep 33 Heavy/Steep
Elevation Slopemap Slope__classes Erosion__classes

500 feet 1 Path 10 Light

5 — 5 — 20 Moderate

2500 feet 200 Paths 33 Heavy
Elevation FlowMap Flow__classes

Command sequence (Script)—

=
Script  Edit
FReclassify 'l Overlay 'l Distance 'l Neighbars 'l Statistical 'l Irnport/E xpart 'l acro 'l
Erosion
Operatian Operation Detal ‘Display |Elean Up
NOTE Simple Erozion Potential Model 20 I_
HOTE Create and interpret a terrain steephess map. 20 I_
SLOPE SLOPE Elevation Fitted FOR Slopemap 2D I_
REMUMBER |REMUMBER Slopemap ASSIGHING 1 TO 0 THRU 10 ASSIGNING 2 TO10THRU 3.. 2D (]
NOTE ...press Continue to proceed; Close to stop the script 2D I_
PALSE Mane O
MOTE Create and interpret a water flow map... 2D I_
DRAIM DRAIM Entire 0WER Elevation Simply Steepest FOR Flowmap 20 I_
REMWUMBER |REMUMBER Flowmap ASSIGHING 10 TO 1 THRU 10 ASSIGNING 20 TO 10 THRU ... 20 (]
PALSE Mane O
MOTE Combine the steepness and flow maps for erosion potential classess map... 20 O
COMPUTE  |COMPUTE Flaw_classes Plus Slope_classes FOR Erosion_classes 20 I_
NOTE [-end of script ] O

E Press the Map Analysis button to pop-up the Map Analysis dialog box.
Select Script-> Open then browse to and select Program Files-> Red Hen Systems-> MapCalc-> MapCalc
Data-> WorkshopData-> Scripts> GM_Ex2_Erosion.scr file.

—_—— peiEs
BEE he e =

Soipt Edt A B 1 | = [ AR G e

Recksssly ~|_ Ovelay -] Distancs - Neighbors _ +|_Stetsioal ~| Import/Export ~|_Maco -]

Erosion

Operstion | Operation Detal ‘D\sp\ay ‘E\ear\ Up

NOTE Simple Erosion Potental Model W O

NOTE Create and interpret a tenain steepness map Eal | m} oren 2ixl

SLOPE  |SLOPE Elevation Fited FOR Slopemap m ] Look in: | 3 Seipts ] « @ ek e

RENUMBER |RENUMBER Slopemap ASSIGNING 1 TO 0 THRU 10 ASSIGNING 2 T0 10 THRU 3... 2D | m} =

Flcampground.ser  [INDVIser

NOTE press Continue to prossed: Close to siop the soript W [} =T osion s

PAUSE Nore [m] = Flvej(expnn&sm

NOTE Create and interpret & waler flow map. o ] [ Fire_Riskscr

DRAIN DRAIN Entire DVER Elevation Simply Steepest FOR Flowmap m r = ["h“j‘;‘““'

= andil.scr

RENUMBER |RENUMBER Flowmen ASSIGNING 10 T0 1 THRU 10 ASSIGNING 20 T0 10 THRU .. 20 O —

FAUSE Nare r

NOTE C and How maps for ) [}

Flenane:  [Erosion ser [Coeen |
COMPUTE | COMPUTE Flow_olasses Plus Slope_classes FOR Erosion_classes m |}
NOTE e oF sol J2o 0 Files of ype: [5 cript fles [sor] - Concel |
|

Resize and position the script window to the lower-left portion of the display window as shown.

Execute the command script a line at a time by double-clicking on the line and interpreting the dialog box information.
Submit a command line by pressing OK.
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The first portion of the erosion model...

MNOTE Create and interpret a terrain steepnass map...
SLOPE SLOPE Elevation Fitted FOR Slopemap
RENUMEER |RENUMEER Slopemap ASSIGNING 1 TO 0 THRU 10 ASSIGHING 2 T0 10 THRU 3...

...creates a map of terrain steepness (Slopemap) then “calibrates” the steepness into three classes (1= Gentle, 2=
Moderate, 3= Steep)

The next portion of the model...

MNOTE Create and interpret a water flow map...
DRAIN DRaAIMN Entire OVER Elevation Sinply Steepest FOR Flowmap
RENUMEER | RENUMEER Flowmap ASSIGHING 10 TO 1 THRU 10 ASSIGNING 20 TO 10 THRU ..

...creates a map of water confluence (Flowmap) then “calibrates” water flow into three classes (10= Light, 20=
Moderate, 30= Heavy)

The final portion of the model...

MOTE Combine the steepness and flow maps for erosion potential classess map..
COMPUTE  |COMPUTE Flow_clazses Flus Slope_classes FOR Erosion_claszes
MOTE ...end of script

...combines the steepness and flow maps into a single erosion potential map to identify each map location by a two-
digit code where the first number (tens digit) indicates the flow class and the second number (ones digit) indicates the
steepness class. For example, 11= Light/Gentle (low erosion potential) and 33= Heavy/Steep (high erosion
potential).

In turn, the erosion potential map can be used in a variety of other models, such as water flow and pooling analysis
for a farmer’s field or in generating a variable-width buffer around spawning streams that reaches farther away from
the stream in areas of high erosion potential.

See http://www.innovativegis.com/basis/Senarios/Default.html for an example applying the Erosion Potential Model to
a central-pivot cornfield in Colorado—

2 ..2-digit code
= Pt =5 class
" 2= F_class

-
]
|
]
. 2
—
|
[}
|

class

Map Analysis [=[0]x]
Sorpt Edit

Reclassty_~|_ Ovey +|_Distance <] Neiwors | Sttt | mpon/Expent <] _Maco <
Tenp

Opecaion Dpersien Dl [Orpay_ [Clnllp
SLOPE | SLOPE Elevaon Fhiec FOR Sopemap )
DRAIN | DRAIN Erive OVER Elevation Srrpl Stsepest FOR Floumap »
RENUMBER | RENUMEER Slopaap ASSIGNING 1 T0 0 THAU 1 ASSIGHING 210 1 THRU 24, 20
ap ASSIGHING 1 T 1 THRU 2 ASSIGNING 2TD 2 THRUS A 20
0] + Flow_classes »
o ASSIHINE 170 17 ASSIGHINE 170 12 ASSGNNG 2.

jm o o o e

ReNUMgER [FETT | 2 Mnderate

B 1 Litle

Command macro for deriving Erosion__Potential Erosion__Pofential

...note: the high erosion potential areas at the edge of the field indicating areas where sediments and chemicals
easily move off the field.
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Cross-reference to ESRI Grid and Spatial Analysis operations...

MapCalc Command

Grid / Spatial Analyst

Slope creates a map indicating the slope (1st derivative) along a

continuous surface. Surface function SLOPE
Drain creates a map indicating the number of steepest paths Hydrologic function
(optimal path density) from a set of locations along a surface. FLOWACCUMULATION
. . Reclassification function
Renumber assigns new values to the categories on a map. RECLASS

Calculate creates a map as the mathematical or statistical function
evaluating an equation using a stack of map layers.

Arithmetic operators
* +, -, DIV, MOD

Joseph K. Berry, BA_SIS, Inc. All Rights Reserved.
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Exercise #3 — Reclassify and Overlay Techniques (MapCalc)

(3a Part 1) Reclassify Operations
Access MapCalc using the Tutor25.rgs database by selecting Start> Programs-> MapCalc Learner-> MapCalc
Learner-> Open existing map set-> Tutor25.rgs in the ...\WorkshopData\ folder.
Part 1. Reclassify Operations. Complete the following commands...
— View Button-> Covertype to display the map (note the shape of W, M and F features)

— SIZE Covertype FOR Covertype_size
This command calculates the area of each “region” (category value) on the map.

Coversype_size

Three “regions”

— CLUMP Covertype AT 1 Diagonally FOR Covertype_clumps
This command assigns a sequential number to all of the individual occurrences (contiguous grouping) of each cover

type “region” (category).

Coverype_clumps

Il

Five new “regions”

— SIZE Covertype_clumps FOR Covertype_clump_size
This command calculates the area of each “region” (category value) on the map ...five separate occurrences of the
three cover types.

Covertype._ciump._sizo

i

1

— CONFIGURE Covertype_clumps Edges FOR Covertype_clumps_edges
This command counts the number of edge cells contained in each of the cover type clumps.

Size of each of the five new “regions”

Joseph K. Berry, BA_SIS, Inc. All Rights Reserved. 6
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(Coverype_clumps_edges

— CONFIGURE Covertype_clumps Convexity FOR Covertype_clumps_shape
This command calculates an index of shape as a function of the ratio of perimeter (edge) to area (interior) where 1=
extremely irregular (almost all edge) to 100 (perfect circle).

Coverype_clumps_shape

The Renumber command simply assigns a new number to a value (or value range) on an existing map. Entering a
series of “reassignment phrases” to generate binary habitat maps is demonstrated below.

— lIsolate locations of gentle slope
— RENUMBER Slope ASSIGNING 0 TO 30 THRU 1000
ASSIGNING 1 TO 0 THRU 30 FOR S_Pref

Select the Slope map —> 1 ==l _= 1| Enter 1in the “New Value” field
Enter 0 in the “New Value” field Enter 0 in the “Old Value” field
Enter 30 in the “Old Value” field Enter 30 in the “Old UpperValue” field
Enter 1000 in the “Old UpperValue” field Press the Add button to record the phrase
Press the Add button to record the phrase Enter the S_Pref map name in the “For” field

Press OK to submit the command

Repeat the Renumber process to isolate Southerly oriented locations
RENUMBER Aspect ASSIGNING 0 TO 1 THRU 9
ASSIGNING 1 TO 3 THRU 7 FOR A_Pref

Repeat the Renumber process to isolate the lower elevations
RENUMBER Elevation ASSIGNING 0 TO 1800 THRU 2500
ASSIGNING 1 TO 500 THRU 1800 FOR E_Pref

(3a Part 2) Overlay Operations

[
Part 2. Overlay Operations. Complete the following commands...

— COMPUTE S_Pref Times A_Pref Times E_Pref FOR Binary_model
Note: Compute phrases are entered using the “Add” button in a similar fashion as Renumber
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Binary_model

Click on the Data Type button to switch the map display to discrete

data type.

— COMPUTE S_Pref Plus A_Pref Plus E_Pref FOR Ranking_model

Ranking_model

m

]
Click on the Data Type button to switch the map display to discrete

data type.

— View Button-> Covertype to display the map (note the map values for the W, M and F features)
— View Button-> Water to display the map (note the map values for the various water features)
— CROSSTAB Covertype WITH Water Simply

=]
Fle Edt Format Yiew Help
Coincidence Tahle For Mapl = Covertype B
with Mapz = water
mapl # of Map2 # O # of % of
value cells value Cells cross Total
1.00 82 2.00 4 4 0.64
.00 82 4.00 58 58 9.28
1.00 82 5.00 20 20 3.20
z.00 22l 0.00 497 152 30.72
z.00 221 2.00 41 27 4.32 B outlet
.00 2zl 6.00 1 0.16 1
.00 2zl 7.00 2 1 0.16 — ;'F':)'ﬁ:
3.00 322 0.00 497 305 48.80
.00 322 1,00 1 1 0,16 "1 5Lake Shore
.00 322 2.00 41 14 2.24 N sLake
300 322 7.00 2 1 0.16 L1 3pond
3.00 322 8.00 1 1 0.16 N 3Forest I 2 stream
= [ 2 Meadow [ 1 5pring
<l 2 [N 1 Open Water 1 obiyLand

The Crosstab table summaries the spatial coincidence between two maps by counting the number of cells for each
combination of the map categories. For example, Map1 (Covertype) value 1 (Open Water) jointly occurs in space
with Map2 (Water) value 3 (Pond) for times (# of Crosses).

— CALCULATE (Covertype * 10) + Water FOR CW_codes

Advanced Equation Editor x|

Maps  Functions
[Covertype * 10] + water

Enter parenthesis to specify order of operation.
Erample: [Layer] - Layer2] * [SqrtLayer3)]

Mew Layer Mame : ICW_code

Ok | Help | LCancel

Click on the menu item “Maps” to select maps that are entered into the
equation as shown.
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(CW_code]

ERwNEzOSE

.,’ . . . .
Click on the Data Type button to switch the map display to discrete

data type.
)
Category Display
Category | Enur\tl aclasl/ Gridded Area Colar | ok
0 1 a7 016 d
70 1 247 os [ M
320 14 34577 Il e
3.0 1 247 [iRT3 - 4
E 305 753278 s -
20 1 247 016 -
260 1 247 016
220 27 BEES4 432 -
200 192 474195 72
150 20 4939% 32 -
140 58 143246 3.23-
130 4 387 o6+ [ . ) . .
Double-click on the map to pop-up its Shading Manager with a tabular

summary of the data. What condition does a “13” identify? How do the “Count” column statistics relate to those in
the Cosstab table?

— COMPOSITE Covertype WITH Slope Average FOR Covertype_avgSlope

Coverype_avgSiops

— RENUMBER Covertype ASSIGNING 0 TO 2 THRU 3 FOR OpenWater_binary
— COMPUTE OpenWater_binary Times Slope FOR OpenWater_slope

OpeniWarer siope.

(3b) GIS Modeling (Habitat Suitability Model that Derives, Calibrates and Combines map layers)
The unique spatial combinations of geographic factors often determine habitat quality. In this example, using the
Tutor25.rgs database Hugags in this locale have shown a preference for...

e Gentle Slopes (<30%)
e Southerly Aspects (E-W)
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e [ower Elevations (<1800 feet)
...are evaluated using computer-based map analysis techniques for Binary, Ranking and Rating suitability models.

Using the flowchart and script listing below, become familiar with the model logic ingrained in each processing step
that leads to the final Hugag habitat suitability map.

=0l
St £t
. . s . Reclassiy -| Ovely | Distance +| Neighbors | Statisical ~|import/Espon +|_Macio |
Conveying Suitability Model Logic e
Dperation | Dperation Detail | Display | Clean Up.
. NaTE ple HabiatMiodele— (s Tu1o5 135 » O
gemtle slopes NaTE Iz e maps of Slope and Aspect IzD O
Siope SLoPE ion Fied FOR Sepenap kS O
Elevation ——  Slope  —— Preference X ORIENT | ORIENT Elevaton Octnts FOR Aspecinan » O
Fad 1109 Cooa | | (Times 1) NOTE o eed; Close to stop the scipt » (m}
PALSE Nene [
southerly aspects NOTE | Einay Modet wihern and o » O
§ RENUMBER | RENUMBER ASSIGNING 070 30 THRU 1000 ASSIGNING 1 T0 0 THRU 30 FOR S_Pref » O
) @ Habitat RENUMEER | ENUMBER £SSIGNING 070 1 THAU 3 ASSIGNIG 1 70 3 THRU 7 FOR &_Pre »
Homin | D ~ Rating' RENUMBER | RENUMBER Elevaion ASSIGNING 0 T0 1600 THAL 2500 ASSIGNING 170 500 THRU 1600 FORE_Prel 20 O
fad 109 Good COMPUTE | COMPUTE 5_Pref Tines A_Pre Times E_Pre FOR B_Habit » O
PAUSE Nene [
lower elevations nore - > O
Elevation @ COMPUTE | COMPUTE S_Pref Plus A_Pref Plus E_Pref FOR R_Hakiat » O
Elevation : PalsE [
Bad 1109 Good Habitat NaTE 1= poot » O
Rating RENUMBER | RENUMBER Slope ASSIGNING 1 T0 40 THRU 1000 ASSIGNING 3T0 30 THRU 40 ASSIGNING 5T0 20 THR... 20 [m]
0=No, 110 9 Good RENUMBER | RENUMBER Aspect ASSIGNING 170 1 THRU 9 ASSIGNING 5T0 3 ASSIGNING 6T0 7 ASSIGNING 3T0 4 .. 2D u]
RENUMBER | RENUMEER Elevalin ASSIGNING 1 T0 1600 THAL 10000 ASSIGNING 3 T0 1400 THRU 1800 ASSIGNING 5. 20 O
. . COMPUTE | COMPUTE S_Pref2 lus A_Pref2 Pl E_Pref2 FOR Tola Sutable » (u}
Base Maps Derived Maps Interpreted Solution COMPUTE | COMPUTE Total_Suitable Dividecby 3 FOR Avg_Sutable 2 O
Maps Map rause [
NOTE | Mack areas o » O
RENUMBER | RENUMBER NING 070 1 ASSIGNING 1 T0 2 THRU 3 FOR Waler_mask » O
COMPUTE | COMPUTE W < Ava_Sutatle FOR Ava_Sultabe_masked kS O
Covertipe PAUSE Nene
NOTE | Cokeite the average habiat sutabiiy o et » (u}
COMPDSITE | COMPO! iots WITH Ava_Suiable_masked Aversge IGNORE PMAP_NULL FOR Disticts_avgSuitable il O
Constraint Map NaTe o o st » (u}

In a manner similar to accessing and implementing the Erosion Potential model in the previous exercise, execute the
Hugag Habitat Suitability model by—

E Within the Tutor25.rgs database, press the Map Analysis button to pop-up the Map Analysis dialog box.

Select Script-> Open then browse to and select ...\Workshop Data-> Scripts> GM_Ex3_Habitat.scr file.

Execute the command script a line at a time by double-clicking on the line and interpreting the dialog box information.
Submit a command line by pressing OK. Relate the processing steps to the discussion in Slide # 5, Part 2 and the
hyperlinked Hugag2.ppt slide set.

Cross-reference to ESRI Grid and Spatial Analysis operations...

MapCalc Command Grid / Spatial Analyst

Slop.e creates a map indicating the slope (1st derivative) along a Surface function SLOPE
continuous surface.

Surface function ASPECT

Orient creates a map indicating aspect along a continuous surface. Distance function
EUCDIRECTION
. . Reclassification function
Renumber assigns new values to the categories on a map. RECLASS
Compute creates a map as the mathematical or statistical function Arithmetic operators
evaluating an equation using a stack of map layers. * 4+, -, DIV, MOD
Zonal functions
ZONALFILL,
Composite creates a map summarizing values from one map that coincide ZONALMAX, ZONAL
with the categories of another. MEAN, ZONALMIN,
ZONALRANGE,
ZONALSTD, ZONALSUM,
ZONALVARIETY
Joseph K. Berry, BA_SIS, Inc. All Rights Reserved. 10
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Exercise #4 — Measuring Distance and Connectivity (MapCalc)

Access MapCalc using the Tutor25.rgs database by selecting Start> Programs-> MapCalc Learner-> MapCalc
Learner-> Open existing map set-> Tutor25.rgs in the ...\WorkshopData\ folder.

Part 1. (Distance and Connectivity). Complete the following commands...

— View Button-> Housing to display the map (note the shape of the road network ...a bunch of dots)

— SPREAD Housing TO 20 FOR Housing_simpleprox

This command generates a simple proximity surface from roads that assumes straight-line connectivity “as the crow
flies”; view as a 3D Grid display of continuous data

Housing_simpleprox

105

@2
3

canusuoN®

— View Button-> Roads to display the map (note the shape of the road network ...like a discus thrower)

— SPREAD Roads TO 20 FOR Roads_simpleprox

This command generates a simple proximity surface from roads that assumes straight-line connectivity “as the crow
flies”; view as a 3D Grid display of continuous data

Housing_simpleprox

105
10
9

canusuoN®

— View Button-> Covertype to display the map (note the values assigned to the various cover types)
— RENUMBER Covertype ASSIGNING 0 TO 1 ASSIGNING 3 TO 2
ASSIGNING 7 TO 3 FOR C_friction
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=
Renumber Covertype -

NewValue 0
0id¥alue 1
Old Uppealue:

ASSIGNING OTO 1

For Newhap =l

RENUMEER Covertype ASSIGNING 070 1FOR
MewMap

oK. | Bz | Help |

Note: Reassignment phrases are entered by specifying the New Value to replace an Old
Value then pressing the Add button to enter the phrase. Repeat for other reassignment phrases.

This command establishes the relative impedance to movement in minutes to cross a grid cell based on cover
types— 0= Open Water (absolute barrier), 3= Meadow and 7= Forest (relative barriers)

— SPREAD Roads TO 75 THRU C_friction FOR Road_hikingprox
This command generates an effective proximity surface from road locations that assumes not necessarily straight
connectivity “as the crow walks” respecting absolute and relative barriers to movement

Road_hikingprox 75 37
™ 36
7 35
72 34
7 33
70 32
89 31
68 30
7 20
66 2
85 a7
64 2
63 25
62 24
81 23
60 2
59 21
58 20
57 1
56 18
55 17
54 i
53 15
52 1
51 13
50 12
1 1
4 10
¥ 9
4 8
45 7
4 [
£ 5
2 4
a 3
4 2

39 1
8 0

— View Button-> Locations to display the map (note the value and location of the Ranch location)
— RENUMBER Locations ASSIGNING 0 TO 2 THRU 5 FOR Ranch
This command isolates the ranch as a new map

— SPREAD Ranch TO 35 Simply FOR Ranch_simpleprox
This command generates a simple proximity surface from the ranch that assumes straight-line connectivity “as the
crow flies”; view as a 3D Grid display of continuous data

Ranch_simpleprox
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— RENUMBER Roads ASSIGNING 1 TO 1 THRU 43 FOR R_friction
This command establishes the relative impedance to movement in minutes to cross a grid cell of any road type— 0=
not road, 1= all road types (relative barriers)

— COVER C_friction WITH R_friction FOR CR_friction
This command combines the cover type and road impedances by replacing C_friction values with R_friction values
other than zero (transparent)

— SPREAD Ranch TO 75 THRU CR_friction FOR Ranch_hikingprox
This command generates an effective proximity surface from the ranch that assumes not necessarily straight
connectivity “as the crow walks” respecting absolute and relative barriers to movement

Ranch_hikingprox

— View Button-> Locations to display the map (note the value and location of the Cabin location)
— RENUMBER Locations ASSIGNING 0 TO 1 ASSIGNING 0 TO 3 THRU 5 FOR Cabin
This command isolates the cabin as a new map

— STREAM Cabin OVER Ranch_hikingprox FOR Path
This command identifies the optimal path (shortest route) as the steepest downhill path over the Ranch_hikingprox
surface

— COMPUTE Ranch_hikingprox times path FOR Path_hikingprox
This command isolates the hiking proximity values for the optimal path between the ranch and cabin

Path_hikingprox. 365

b,
R,
< o
RIS S SCERSO,
I e
S SO IS SISO

SOCSSS ‘:‘““:«‘:‘ 18

S ) .
j Part 2. (Visual Exposure). Complete the following commands...

— RADIATE Ranch OVER ELEVATION TO 35 AT 5 SIMPLY
FOR Ranch_viewshed

Joseph K. Berry, BA_SIS, Inc. All Rights Reserved. 13
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This command generates a map that identifies all of the locations that can be seen from the ranch

Ranch_viewshed

Viewshed usig the SMPLY mehad fvistie oo =1)

— RADIATE Roads OVER ELEVATION TO 35 AT 5 SIMPLY
FOR Roads_viewshed
This command identifies all of the locations that can be seen at least once from any of the road locations

— RADIATE Roads OVER ELEVATION TO 35 AT 5 COMPLETELY

FOR Roads_VExposure
This command generates a surface that identifies the number of road locations visually connected to each location in
the project area—visual exposure density surface

Roads_vexposure

SN

wwwww )

— RADIATE Housing OVER ELEVATION TO 35 WEIGHTED
FOR housing_WeightedVE

The following series of commands complete a simple model that generates a map identifying the relative visual
exposure index of human activity

Joseph K. Berry, BA_SIS, Inc. All Rights Reserved. 14
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Visual Exposure Index

. (Housing and Roads)
Housing Housing_ | o Housing_ | I
WeightedVE | @ VE_Index m
Elevation w
N
-
— 3
=
=T
Roads Roads_ | & | Roads_ ||
VExposure @ VE_Index
Elevation
L -
Low High

— SLICE Housing_WeightedVE INTO 4 FOR Housing_VE_Index
This command (under the Reclassify group of operators) divides the range of weighted visual exposure to housing
into 4 classes from 1= low to 4=high

— SLICE Roads_VExposure INTO 4 FOR Roads_VE_Index
This command divides the range of weighted visual exposure to roads into 4 classes from 1= low to 4=high

— ANALYZE Housing_VE_Index WITH Roads_VE_Index Mean FOR RH_VE_Index_avg
This command (under the Statistics group of operators) averages the two index maps

Cross-reference to ESRI Grid and Spatial Analysis operations...

MapCalc Command Grid / Spatial Analyst

Distance functions
CORRIDOR (compute
sum), COSTALLOCATION
(slice), COSTDISTANCE,

T L EUCALLOCATION,
fgg:;lﬁi Cclrceflist (c)l Z;laf))t;lnecf’l?jctzgoie shortest effective distance from EUDIRECTION (orient),
’ EUCDISTANCE

Shape Analysis functions
EXPAND, SHRINK

Hydrologic function
WATERSHED, BASIN
. . Reclassification function
Renumber assigns new values to the categories on a map. RECLASS
Radiate creates a map indicating areas that are visible from specified Visibility tools
locations VISENCODE,
’ VISIBILITY
Selection functions
Cover creates a new map where non-zero values of the top map replace SELECTBOX,
the values on the previous (bottom) map, or stack of maps. SELECTCIRCLE,
SELECTMASK,

Joseph K. Berry, BA_SIS, Inc. All Rights Reserved. 15
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SELECTPOINT,

SELECTPOLYGON

Distance functions
COSTBACKLINK,

Stream creates a map identifying the steepest downhill route along a

surface (optimal path).

COSTPATH,
PATHDISTANCE
Hydrologic function
FLOWDIRECTION

(orient)

Joseph K. Berry, BA_SIS, Inc. All Rights Reserved.
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Exercise #5 — Characterizing Spatial Neighborhoods (MapCalc)

Access MapCalc using the Tutor25.rgs database by selecting Start> Programs-> MapCalc Learner-> MapCalc
Learner-> Open existing map set-> Tutor25.rgs in the ...\WorkshopData\ folder.

o
Complete the following commands...

— SCAN Covertype DIVERSITY WITHIN 2 FOR Covertype_diversity2
...how many cells are within 2-cells of all three cover types?

Coverype_diversity2

— SCAN Covertype DIVERSITY WITHIN 4 FOR Covertype_diversity4
...how many cells are within 4-cells of all three cover types?

Coverype_diversity4.

— SCAN COVERTYPE DIVERSITY WITHIN 4 AROUND ROADS
FOR Covertype_diversity4_roads
...where are the most diverse locations along the road network?

Covertype_diversity4_roads|

n

— SCAN ELEVATION AVERAGE WITHIN 4 FOR Elevation_smooth4
— COMPUTE ELEVATION MINUS Elevation_smooth4 FOR Convex_concave_terrain
...what information does the positive and negative sign convey? ... the magnitude of the values?

Joseph K. Berry, BA_SIS, Inc. All Rights Reserved. 17
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Convex_concave_tora]

Convex_concave_terrain over Elevation

snadhERbd

— SCAN SLOPE COFFVAR WITHIN 1 FOR Slope_roughness
...what is the maximum localized slope variation? ...where is it?

‘Slope_roughness|

‘Slope_roughness over Elevation

H ey
— SLOPE SLOPE FOR What?
...what do you think the values indicate?
[what?| Siope_roughness over Siope.
.

Skpa massasd v percset g e FITTED method

— RENUMBER Ranch_hikingprox ASSIGNING PMAP_NULL TO 100

FOR Ranch_hikingprox_mask

(Ranch_hikingprox from the previous exercise)

— SLOPE Ranch_hikingprox_masked FOR What_else?

...what do you think the values indicate?

What_else?|

Sl messuedin porcet g e FTTED metrod

What_else? over Ranch_hikingprox_mask|

Joseph K. Berry, BA_SIS, Inc. All Rights Reserved.
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— ORIENT Ranch_hikingprox_masked FOR You_have_to_be_kiding!
...what do you think the values indicate?

Yoy_have_to_be_kiding|

Yoy_have_to_be_kiding! over Ranch_hikingprox_mask

Cross-reference to ESRI Grid and Spatial Analysis operations...

MapCalc Command

Grid / Spatial Analyst

Scan creates a map summarizing the values that occur within the vicinity
of each cell.

Statistical operation
POPULARITY
Focal functions
FOCALFLOW,

FOCALMAX,
FOCALMEAN,
FOCALMIN,
FOCALRANGE,
FOCALSTD, FOCALSUM,
FOCALVARIETY
Conditional statement
IF, WHILE, DOCELL
Data Clean-up functions
BOUNDARYCLEAN,
MAJORITYFILTER,
NIBBLE, THIN
Hydrologic functions
FILL, SINK

Compute creates a map as the mathematical or statistical function
evaluating an equation using a stack of map layers.

Arithmetic operators
* +, -, DIV, MOD

Profile creates a map indicating the cross-sectional profile along a

Surface functions

combinations of the values on two maps.

continuous surface. SAIL, SHADE
Intersect creates a map by assigning new values to pair wise Combinatorial function
COMBINE

Joseph K. Berry, BA_SIS, Inc. All Rights Reserved.
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Exercise #6 — Surface Modeling (Surfer)

Installing Surfer— The Workshop CD comes with a evaluation copy of the Surfer software (cannot save
or print plots). To install Surfer press Start> Run-> then browse to the ...\ Workshop\Surfer\ folder on
the CD and select the s8demo.exe file. Follow the onscreen installation instructions. It is recommended
that you accept the default specifications as the exercise write-ups assume this installation location.

Accessing MapCalc— To access Surfer press Start> Programs-> Golden Software Surfer 8->
Surfer 8. Click anywhere to dismiss the banner graphic and follow the exercise directions below to
create and display map surfaces.

Uninstalling MapCalc— To uninstall Surfer press Start> Control Panel-> Add or Remove
Programs—> and select Surfer 8 to remove.

Part 1 — Spatial Interpolation. Access the Surfer software system by double-clicking its icon on the desktop
or by pressing Start-> Programs—> Golden Software Surfer 8-> Surfer 8.
Create a continuous grid from discrete point data...

v" From the main menu click Grid - Data, then select the Demogrid.dat file in the ...\Samples subdirectory. The
Scattered Data Interpolation box will pop-up.

Grid Data - D:\Program Files'\Golden Softwares 2 x|

Data Columns  [47 data paints]
% | Column &; Easting Filter Data...
Cancel

El
A IEqumn B: Marthing j View Data
j Statistics W Grid Report

2: | Column C: Elevation

Gridding Method

’V VI Advanced Options... | ‘ Cross Va\idate...l
Output Gd Fil

’VI [:\Progiam FilesiGolden Software\Surferd\Samples\DEMOGRID.ord =

Grid Line Geometr

Minimurn b aimnum Spacin # of Lines
* Direction: ID k| (1.09030303051 |1DD 33

¥ Directior: [0 |7 IERETEE T

Data Columns enables the selection of X, Y and Z data fields in a table

Gridding Method box specifies the interpolation techniques (use Kriging)

Output Grid File to browse to a folder for storage of the interpolated map

Grid Line Geometry sets the analysis frame configuration by defining the extent and cell size (use defaults)

ANENENEN

Click OK to derive the interpolated surface using default specifications

View a map surface as a contour map...

v" From the main menu click MAP - Contour > New Contour map > OPEN and specify the
Demogrid_IDW.grd data file you just derived. Click OK to generate a contour plot...

Joseph K. Berry, BA_SIS, Inc. All Rights Reserved. 20
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View a map surface as a “surface” plot...

v" From the main menu click MAP - Surface - OPEN and specify the Demogrid_IDW.grd data file you just
derived. Click OK to generate a “surface” plot...

AV
VA
? ;@V

Graphically overlay the two plots...

v Shift/click both plots to select them, then from the main menu click MAP - Overlay Maps to generate a
“surface/contour” plot...

Surfer contains several different spatial interpolation methods. Repeat the processing to create another surface

using Inverse Distance Weighted interpolation technique.

v" From the main menu click Grid > Data, then select the Demogrid.dat file in the ...\Samples subdirectory. The
Scattered Data Interpolation box will pop-up.

Grid Data - D:Program Files'Golden Software\Surfers ﬂﬁl

Data Columng (47 data paints)
% | Colurmn A Easting =l Filter Diata
Cancel

Y IEﬂIumn B: Marthing j View Data
Z: [Colurn C: Elevation | Statistics ™ Grid Fiepart

Gridding Method

’VIInverss Distance to a Power j Advanced Options... | ‘ Cross Validate... |
Output Gd Fil

’VI C:\Progiam FilesiGolden Software\SurferdySamples\DEMOGRID _IDW. ard =
Grid Line Geometr

Minimurn I &imnum Spacin # of Lines

¥ Direction: IU 9 0.09090903091 |1UU 32
¥ Ditectiar: [0 Iz | [EEEEEE =

However this time, specify “Inverse Distance to a Power” as the
Gridding Method and DEMOGRID_IDW.grid as the Output Grid File.

Generate a Contour map and a Surface map and then overlay the maps as before. Repeat for other interpolation
techniques as time and interest permits.
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Krig

Minimum Curvature Modified Shepard’s

As time and interest permits for optional homework, complete the Surfer Tutorials in the
...\Geotechnology_software\Surfer\Surfer_Tutorial\ folder on the Workshop CD.

Part 2 — Density Analysis. For a related experience in Surface Modeling using density analysis, access
MapCalc using the Smallville.rgs database by selecting Start> Programs—> MapCalc Learner-> MapCalc
Learner-> Open existing map set-> Smallville.rgs in the ...\WorkshopData\ folder.

[
Complete the following commands...

— View Button-> Total_Customers to display a map identifying the number of customers at each grid location
— SCAN Total_Customers TOTAL WITHIN 6 FOR Customer_density6
This command determines the total number of customers within a specified reach to generate a density surface.

— Right-click on the map and select the Shading Manager. Click on the Statistics tab and note that the average
customer density is 17.7 with a standard deviation of 16.0. The breakpoint for unusually high customer densities is
17.7 + 16.0= 33.7.
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— RENUMBER Customer_density6 ASSIGNING 0 TO 0 THRU 33.7
ASSIGNING 1 TO 33.7 THRU 1000 FOR Customer_highDensity

This command isolates the locations of high customer density (assigned a value of 1 embedded in zeros)

Customer. r_highDensity|

Cross-reference to ESRI Grid and Spatial Statistics operations...

MapCalc Surface Modeling Command

Grid / Spatial Analyst

Inverse Distance Weighted performs an inverse distance weighted

Statistical Function

interpolation of point data. IDW
Kriging performs spatial interpolation of point data using the Statistical Function
Kriging algorithm. KRIG

Grid math creates a map as the mathematical or statistical
function evaluating an equation using a stack of map layers.

Arithmetic operators
* +, -, DIV, MOD

Joseph K. Berry, BA_SIS, Inc. All Rights Reserved.
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Exercise #7 — Spatial Data Mining (MapCalc)

Access MapCalc using the AgData.rgs database by selecting Start> Programs-> MapCalc Learner-> MapCalc

Learner-> Open existing map set-> AgData.rgs in the ...\WorkshopData\ folder.

dh

Visually compare the yield maps for 1997 and 1998.

1998 Yield Volume

minus

1997 Yield Volume

Note: to visual compare to map surfaces, you MUST use the same display types and legend.

00 bulae
280 bulae
260 bulae
240 trfac
220 bfae
200 belac
180 budac
160 bulac
140 bulae
120 bulae
100 bulae
80 bufac
B0 bifac
A0 btz
20 befac
i bulac

Press the Map Analysis button to access the analytical operations then select Overlay—> Calculate and
complete the dialog box as shown below using the Columns item to select maps and Functions item to select

mathematical operations.

Advanced Equation Editor El

Columns  Eunclions
[1338 isld Yolume - 1997 Yield Yolume

Enter parenthesis to specify order of operation
Example: (Layer] - Layer?) * (Sqr{Layer3))

MNesw Layer Name : [vield_diff
Ok | Help | Cancel

LI

1 1998 Yield Volume — 1997 _Yield Volume For Yield_diff

(negative values displayed as warmer tones).
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Min: -191
Max: 165
Range: 356
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20 v 9 it
0 1 a2 2 14 ot Mediar: 26.3
I TIC
. St Dev w5
120 oo o Variahce: 1.054
L i o ooy Gridded Area: 189 acres
200 e 2 e =
Yield_difference
w ¥
"
5 B 0
= 150
o " it
F , -
~ 100
LT .
n
. d h 8
(] 0
[ i v o
. %
e 7 Lyl -
. - o
ey 5 o
R -
. =
-
T e e
...note that most field locations yield decreased in 1998
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|Yietd_ditterence

ETETE] [ oo eI

ovrange wedows without overla (vrticaly)

Generate side-by-side map displays of the 1996_Fall_N, 1996_Fall_K and 1996_Fall_TotalN.

R Lo oo e JETE] | over 1555 Fol oy

1996_Fall_ﬂ 1996_Fall_K 1996_Fall_TotalN|

¥ 185 ppm 195 ppm
— B - s

95 ppm. 6.3 ppm

a | | ...using the same display type and legend and then
pressing the “Arrange Windows without overlap (vertically)” button

Double-click on the Phosphorus map (1996_Fall_P) to pop-up the Data Inspection tool and note how the values for
all of the map layers change as you move about the map. Move the cursor to Column 47, Row 11 (position shown in
bottom left corner of the display window) and note the values for...

1996_Fall_P=33.3 1996_Fall_K= 204.1 1996_Fall_TotalN= 28.9 ppm.
E
Colurnn Name Walug Un =
Latitude: 32329340

Langitude -142.028237
Yeris_Shallow_Canductivity 138516 ma
Weris_Deep_Conductivity 22 6073 mss
Order_lll_Soil_Survey 20-BI&
1997_Yield_Yolume 172.286  busc
1997 _ield_Mass 9,703.96 Ibse
1997_Yield_Moisture 17.424
1996_Fall_P 333457 PE
1996_Fall_K 204.076 o=
1996_Fall_%0M 1.48776
1996_Fall_pH 7.20796
1996_Fall_NO3N 249186 o]
1996_Fall_Zn H.EG046 PE
1996_Fall_NH4N 396336 o=
1996_Fall_#Sand 80,4407
1936_Fall_%Sil 8.06034
1996_Fall_*Clay 11.493

Entire 10
1996_Fall_TotalM 28.882

Elevation 4.447.42

:1@ iald Unhins 181 111

RELATE ((1996_Fall_P, 1, 33.3) WITH (1996_Fall_K, 1, 204.1), (1996_Fall_TotalN, 1, 28.9) FOR
PKN_similarity_47_11

This command generates a similarity map based on the “data distance” relationship of the data pattern of a specified
location to all other locations. Higher values indicate increasing similarity (100= identical).
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[PKN_similary_47_11

i
I;‘l.'l- * =

CLUSTER 1996_Fall_P WITH 1996_Fall_K, 1996_Fall_TotalN USING 2 FOR PKN_cluster2
This command subdivides the field into two zones based on the P, K and N data patterns.

PKN_cluster2

COMPOSITE PKN_cluster2 WITH 1997_Fall_K Average IGNORE PMAP_NULL FOR PKN_cluster2_avgK
This command averages all of the Potassium (K) values occurring within each of the data zones noting that Zone 1
average is 207 ppm compared to Zone 2 at 156 ppm.

207 average - 207 pom
1 56 awrage ke 156pm

»

From the main MapCalc menu, select Map Set-> New Graph-> Scatter Plot and specify 1996_Fall_P as the X axis
(independent variable) and 1997_Yield_volume as the Y axis (dependent variable) and press OK to generate a
scatter plot of the two map variables.

Regres=zion Bquation: w = 19E2 - 2.5 " x (R"2 = 9.8%)

Note: the Univariate Regression equation suggests a negative correlation with increasing amounts phosphorous.
This is likely a spurious result as the scatter plot has minimal overall trend with the low R-squared value of 9.8%
primarily the result of the few outlier high P values. The bottom line is that this regression prediction equation is not
useful.
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REGRESS 1997_Yield_Volume WITH 1996_Fall_P, 1996_Fall_K, 1996_Fall_TotalN TO
C:\Temp\97Yield_PKNregression.txt FOR 1997_Yield_PKNregression
With I hd

1995 _Fal P
Add 1395_Fal K
1996_Fal_Tatal

Del

I~ Ta ID “Projects\DUAGM course0EsM
™2 For IT 997_Vield_PKMNregression  +

B\ 97YIELD_PKNREGRESSION.TXT - Notepad

i ] 53]
REGRESS 1997_ield_Yolume WITH 1995_FallF, Fie Edt Format view Help
1935_Fal_K, 1335_Fall TotalN T0
D Projects\ DU G comse 8 Mapt ale . . =l
Data37Vield_PKNiegression.tst FOF; Least sSquares Coefficients
v Est = 184.003 - 0.736 % 1096_Fall_TotalM + 0.160 * 1996_Fall_K - 2.60L * 1896_Fall_p
-
o | Cancel | wee || 5l

This command generates a Multivariate regression equation predicting Yield from nutrient maps of P, K and N. By
requesting a map be generated, a map of the predicted yield is generated...

1997_Yiald_PKNregression

1897_vield_Voiume,

Predicted Yield map Actual Yield map

The predicted and Actual yield maps are not very consistent. In practice the inconsistent yield values along the field
edge and access road in the southwest portion of the field would be eliminated to yield a much better prediction

equation. Also, a regression tree based on stratified portions of the field would be used to improve the overall
prediction.

Cross-reference to ESRI Grid and Spatial Statistics operations...

MapCalc Spatial Data Mining Command

Grid / Spatial Analyst
Similarity quantifies the similarity of a map to an evaluation data

pattern, or set of comparison values. No comparable operation
Cluster identifies areas with similar characteristics on a set of map Image Analyst
layers. CLUSTER
Correlate derives a correlation matrix from a stack of maps. énéz}gle'\'gﬁl;‘sﬁt‘
Regress performs linear regression analysis by using the "least Statistical function
squares" method to fit a line through a set of data points in

multiple maps. REGRESSION

Joseph K. Berry, BA_SIS, Inc. All Rights Reserved.
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Exercise #8 — Gaining GIS Modeling Experience (MapCalc)

Access MapCalc using the Bighorn.rgs database by selecting Start> Programs-> MapCalc Learner-> MapCalc
Learner-> Open existing map set-> Bighorn.rgs.

Complete the following ...

Part 1 — Campground Suitability Model

ELEVATION ° SLOPEMAP H S_PREF
— g— — 5 — = ...prefer gentle slopes
@
ROADS - PROX_ROADS | & | R_PREF
H
= £ — E — —  ...prefer to be near roads
w @
['4
WATER o PROX_WATER | £ | W_PREF
H
E
= £ — 2 f ...prefer to be near water
w (3
'3
ELEVATION
WATER g | VEXPOSE_W 3 | V_PREF
B .
=3 — E— —  ...prefer good views of water
« &
ELEVATION ASPECTMAP s | A_LPREF
E a
= g — — E — —  ...prefer westerly orientation
&
Base algarthm Derived cultbrate  Interpreted
Maps Maps Maps
P P P . SUITABILITY
EN
- -ge . a
Suitability= fn (Elevation, Roads, Water) combme <
Campground Suitability Model  (Flowchart)
Map Analysis M [=] 3
Script Edit
Reclassiy | Oveay  +| Distance  ~| Meighbors +| Statisical | Impo/Export <] Macio <
Gentle slopes Suiebilty \
Operation |Dpelalion Detail Display JCIenn Up
Near roads NOTE MnunlawnDevflagmenlﬁuwlahiln{y Model 20 L]
SLOPE SLOPE Elevation Fitted FOR Slopemap 2D |
N, ¢ SPREAD  |SPREAD Roads NULLVALUE PMAP_NULL TO 200 Uphill Only Simply FOR: Prox_ioads 20 O
N € e \ Ja
iVedar Waler <—gepaeap  |SPREAD Water NULLVALUE PMAP_NULL TO 200 Uphil Ony Simply FOR Pros_water 2D O
. /4 RADIATE RADIATE Water OVER Elevation TO 200 AT 1 NULLVALUE 0 Completely FOR VEX.. 2D {5
Good views ORIENT | ORIENT Elevation Octants FOR Aspectmap 20 O
RENUMBER |RENUMBER: Slopemap ASSIGNING 9 T0 0 THRU 5 ASSIGNING 7 TO § THRU10... 2D O
Westerly RENUMBER |RENUMBER Prox_oads ASSIGNING 3 T0 0 THRU 5 ASSIGNING 7 T0 5 THRU 10... 2D 0
RENUMBER |RENUMBER: Prox_water ASSIGNING 3 TO 0 THRU 8 ASSIGNING 7 TO 8 THRU 16... 2D O
Calibrate <«———«RENUMBER [RENUMBER VEXPOSE_W ASSIGNING 1 TO 0 THRU 5 ASSIGNING 3TO S THRU ... 20 l‘
RENUMBER |RENUMBER Aspectmap ASSIGNING 3TO 6 THRU & ASSIGNING 7 TO 1 THRU 2... 2D O
C(]mbine «— 4 ANALYZE  |AMNALYZE R_pref TIMES 1 WITH R_pref TIMES 1'WITH W _pref TIMES 1TWITHA_... 2D W
|RENUMEER | RENUMBER: Prox_water ASSIGNING 0 TO 0 THRU 3ASSIGNING 1 T0 3 THRU 20... 20 O
RENUMBER |RENUMBER Slopemap ASSIGNING 1T0 0 THRU 20 ASSIGNING 0T0 20 THRU ... 2D O
Mask <«———4COMPUTE |COMPUTE NO_slope Times NO_piox FOR Constraints P O
COMPUTE |COMPUTE Constraints Times Suitabilty_average_weighted FOR Suitabilty_masked .. 2D O

Campground script
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Implementing the Basic Campground Suitability Model

From the Map Analysis menu, select Scripts> Open and select ...\Scripts\GM_Ex8_Campground.scr.
Execute it a command line at a time under the direction of the instructor. Relate the map analysis operations to the
logical flow identified in the flowchart of the Campground Suitability Model and described in the workshop
presentation.

ELEVATION SLOPEMAP $_PREF

SUITABILITY (Equal Weights}

Non-WEIGHTED ’i

ROADS PROX_ROADS R_PREF
ﬁ 64% Marginal+
WATER PROX_WATER W_PREF 9 Excellert
- 8 Yery Good
7 Good
& Marginal

s

ELEVATION

ELEVATION

™

1 Unacceptable
0 Constrained

6% Marginal+

SUITABILITY (V_PREF weighted * 10)

Implementing another point of view (change decision criteria weights)

Generate a different campground suitability map by interactively completing the following sequence of commands...

Map Analysis 9 =]

Script  Edit

Reclassify 'l Owerlay 'l Distance 'l Meighbars 'I Statistical 'l Imnport/E spart 'l Macro 'l

ewS cript
Operation Operation Detail Digplay |Elean Up
NOTE ki odel Modific ation 20 I_
NOTE MOTE... muszt run Campground. scr firgt = 20 I_
AMNALYZE | AMALYZE S_pref TIMES 6WITH R_pref TIMES 7 *%/ITH V_pref TIMES 4 WITH ¥ _pr... 2D O
COMPUTE  |COMPUTE Potential_average? Times Constraints FOR Potential_maskedz2 20 I_
COMPUTE  |COMPUTE Potential_masked Minuz Potential_masked2 FOR Potentrial_change 20 I_

1) Enter a new Analyze command that weights the five preference maps that are weight-averaged as...

ANALYZE S_pref TIMES 6 WITH R_pref TIMES 7 WITH W_pref TIMES 4
WITH V_pref TIMES 10 WITH A_pref TIMES 1 FOR Potential_average2

...to reflect their relative importance.
2) Use the Compute command to mask the constrained areas.
3) Use Compute to compare the simple average and weighted-average maps.

...What was the greatest change? Where did occur? Which decision scenario (Potential or Potential2) had the
higher rating?
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Part 2 — Optional Exercise in Modeling — Electric Transmission Line Routing Model

“Algorithm” “Calibrate” “Weight”
AVOID
HOUSING AREAS OF
HOUSES [— DENSITY | | HIGH I END
HOUSING
DENSITY
BEST
START ROUTE
AVOID
AREAS THAT
PROXIMITY ACCUMULATED
ROADS | 1ogoaps || AREFAR i — Preference
RRan SURFACE
ROADS
AVERAGE
Freference “Bost Preferred Path”
PROXIMITY avon
SENSITIVE TO IN OR NEAR
AREAS SENSITIVE
AREAS SENSITIVE
AREAS . s . . .
...the individual criteria are translated into
“preference maps” indicating relative
ELEVATION | VoD preference for siting a transmission line
VISUAL AREAS OF at every location in the project area. The
[ EXPOSURE —— HIGH  —— individual preference maps are combined
HOLSES USRS Exmoe e into an average preference map used to
U calcuiate the “most preferred path”
connecting the start and end locations of
Base Derived Preference the best route for the transmission line.
Maps Maps Maps

AT

Script  Edit

Reclassify 'l Overlay '| Distance 'l Meighbors Y| Statistical  +| Import/Export Y| tacro '|
Tranzmnizzion_line

Operation Operation Detail Digplay =
MOTE TRAMSMISSION LIME SITIMG MODEL - uses Bighom.rgs database 20 —
HOTE 1] Calculate Derived Maps 2D
SCAN SCAM Houses Total IGMORE 0.0%ITHIM 15 CIRCLE FOR Housing_density 20
SPREAD SPREAD Roads MULLYALUE PRAP_MULL TO 100 Simply FOR Road_proximity 2D

SFREAD SPREAD Sensitive_areas NULLYALUE PMAP_WULL TO 100 Simply FOR Sensitivedr... 20D
RADIATE RADIATE Houzes OVER Elevation TO 27 AT 1 NULLYALUE 0 Completely FOR Hous... 2D
MOTE 2] Interpret Derived Maps for Individual Cast Maps [1= low cost through 9= high cost) 2D
REMUMEBER | REMUMBER Housing_density ASSIGMING 1 TO 0 THRU 5 ASSIGHING 3TOS5 THR... 2D
REMUMEER |REMUMBER Fload_prosimity ASSIGNING 1 TO 0 THRU 2 ASSIGNING 3 TO 2 THR... 2D
RENUMEBER |REMUMBER Sensitivedreas_proximity A55IGNING 9 TO 0ASSIGNING 6T0 .001 T... 2D
REMUMEER |REMUMBER Houses_ visualExposure ASSIGNING 1 TO 0 THRU 8 ASSIGNING 3T... 2D

MOTE 3] Calculate Average Cost for siting a transmizzsion line at each map location 20
ANALYZE AMALYZE Cost_housingD ensity TIMES 1WITH Cost_roadProximity TIMES 1WITH C... 2D
MOTE 4] |dentify Least Cost Path for the transmizzion line 20

SFREAD SPREAD Powerline MULLWALUE PMAP_WULL TO 500 THRU Cost_simpledverage 5... 2D
STREAM STREAM Power_substation OVER AccumulatedCost_simpledwerage Simply Steepest .. 2D
COMPUTE  |COMPUTE Fioute_simpledwerage Times Cost_simpledverage FOR Route_cost_simple... 2D
MOTE ...end of script 20 ;I

Implementing the Basic Transmission Line Routing Model

From the Map Analysis menu, select Scripts> Open and select ...\Scripts\GM_Ex8_Powerline.scr. Execute
it a command line at a time under the direction of the instructor. Relate the map analysis operations to the logical
flow identified in the flowchart of the Electric Transmission Line Routing Model and described in the workshop
presentation.
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s

- % 5 B 5 o~ Calibration
ol m @ Walgting

..

p
—‘ L ...the individual criteria are translated into

“preference maps” indicating relative
preference for siting a transmission line
at every location in the project area. The
individual preference maps are combined
into an average preference map used to
calculate the “most preferred path”
connecting the start and end locations of
the best route for the transmission line.
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Optional Exercise — Data Exchange Procedures (MapCalc)

This exercise provides experience in data exchange using MapCalc. Complete the exercise following the instructions
and screen grab then embed results within the instructions as you deem appropriate to document and describe your
experience.

SESSION 1. Creating Your Own Database (Empty Map Set)
SESSION 2. Importing Data via Add New Layers

SESSION 3. Importing Data via the Map Analysis Tool
SESSION 4. Importing Data via the File Tool

SESSION 5. Exporting Data via Map Analysis Tool
SESSION 6. Exporting Data via File Tool

SESSION 7. Seamless Data Exchange with Surfer
SESSION 8. Seamless Data Exchange with Maplinfo

Note: data for this exercise is in the ...\Workshop Data\Special Data\ folder on the Workshop CD

SESSION 1. Creating Your Own Database (Empty Map Set)

Click on the Create a new file button or from the main MapCalc menu, select File-> New.

Specify a name for your new data base (e.g., NewDataBase) then press Next.

Click on Create Empty Map Set button to pop-up the Grid Parameters dialog box.

Grid Parameters

Lower Left Comer
|7Latlude [deg) |4U 327805

Longitude [deg]  |-140.035717

Cell Size ISD ft
Fows I84
Cols IEFJ

Ok | Cancel |

Specify the Latitude and Longitude of the lower-left corner of the analysis grid (e.g., Lat=
40.327905, Lon= -140.035717). Note: MapCalc Evaluation and Learner versions require Lat/Lon WGS84 datum.
Academic and Professional versions accept data in a variety of geographic references.

Enter the Cell Size (e.g., 50 feet) and the number of Rows and Columns comprising the analysis grid area (e.g., 64
rows and 66 columns). Click OK to create the empty database.

Data can be entered into the new MapCalc database via several import procedures (see below).

Note: The MapCalc Evaluation and Learner versions can configure analysis grids up to 100 rows by 100 columns.
Grid configuration for MapCalc Academic and Professional versions are not software limited but storage and
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processing requirements are exponential. Interactive processing of grids larger than 500 x 500 is not
recommended—use batch process through scripts for large grid configurations.

SESSION 2. Importing Data via Add New Layers

@& Manage Layers..
VG Map Analysis...
New Giaph 3

MepSet] |3 scttentoms. | Ty import an ESRI .shp or Maplnfo .tab polygon file, select Map Set-> Add New Layers to pop-
up the Adding New Layers wizard.

s | Press the Add File button and specify a file (e.g., Survey.tab), select the data
column(s) to use (e.g., SOILTYPE) and click Next. Click Finish to create the map.

,])

Imported Soil Survey Map from a Maplinfo .tab file

If you have a field boundary map in .shp or .tab format you can use it to directly derive the database configuration.
Instead of creating an Empty Map Set (section SESSION 1, step 2) press the Add New Layers button as described
above. The Latitude and Longitude coordinates will be automatically assigned based on the extent of the boundary

file.

SESSION 3. Importing Data via the Map Analysis Tool
Importing data via the Map Analysis tool accepts grid files for individual maps in three standard formats—

Bare Bare ASCII matrix of values, row major order
Grid  Grid ASCII format (ESRI Software)
Surfer Surfer ASCII format (Golden Software)

...See section SESSION 5, Exporting Data via Map Analysis Tool for descriptions of these standard grid file formats.

The grid files must have the same configuration as the active database-- #Rows, #Columns, Cell Size and lower-left
Registration Coordinates.

Import
Fom  Browse | [B

a
Select & Bue

© ESRI (Gridbscil
© Surfer [Aeci]

HulValue [PMaP_NULL -

[V Origin (Lower Ledt Cormes)

For | Drganic_matter hd

IMFORT D:\Frogiam Fles\Red Hen

5 ystems\hapCaict MapCalc DalzPé_hapCalc
DatzADGANICMAT TER. TXT BARE NulValus
P4P_NUILL Drigin Cartesian FOR Organic_matter

x| o] = | For example, add data in Bare format to the NewDataBase (see SESSION 1 above) by
entering Map Analysis—> Import and completing the Import dialog box as—ORGANICMATTER.TXT, Bare,
Organic_matter.
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Imported Organic Matter data Map from a Bare matrix (.txt)

SESSION 4. Importing Data via the File Tool

Importing data via the File tool accepts grid files for individual maps in four standard formats—

Bare Bare ASCII matrix of values, row major order
Grid  Grid ASCII format (ESRI Software)

Surfer Surfer ASCII format (Golden Software)

MIG  Binary Grid format (MaplInfo)

...See section SESSION 5, Exporting Data via Map Analysis Tool for descriptions of these standard grid file formats.

The grid files must have the same configuration as the active database-- #Rows, #Columns, Cell Size and lower-left
Registration Coordinates.

Import

Select B

 ESRI (Gridsei)
& Surfer [Aeci]

HulValue [SURFER_NUILL -

I | Ooriem {Lagen et Bormer)|

For [Sand_percent -

[MPORT D:\Progiam Fles\Red Hen
ystems\MapCalc\MapCale DataPé_MapCac

Da1ASAND %, GRD SURFER HulValue

SURFER_NULL igin Cartesian FOR Sand_p

o | e ] ] oy example, add data in Surfer format to the NewDataBase (see section SESSION 1
above) by entering File=> Import-> and completing the /mport dialog boxes as shown—%SAND.grd, Surfer (Ascii),
Sand_percent.

SESSION 5. Exporting Data via Map Analysis Tool

Exporting data via the Map Analysis tool creates a grid file for individual maps in four standard formats—

Point  Column, Row, Value (nulls skipped)

Grid Grid ASCII format (ESRI)

Bare Bare ASCII matrix of values, row major order
Surfer  Surfer ASCII format (Golden Software)

Select Map Analysis> Import/Export-> Export to pop-up the Export dialog box.

Export
Export Elevation

Select . Paint
© ESR(Gridasc)
C Bae

|l il
| o e i

NulValue [SURFER:_NOLL 5
Columns/DutputLine [10 =

To

[EXPORT Elev:
T D:\Projets!

= =) E=J | Select the Elevation map, specify Surfer (Ascii) and Browse/Name the file for export
(Elevation.grd). Press OK to create the file.
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B ELEV.GRD
Fie Edi View at

NEEE | :*'ak |
osn |

66 54
-142.0357208 -142.0250092

32.32790375 32.33668137

4440.64 4453.4

1.70141E+038 1.70141E4038 1.70141E4038 1.70141E+038 1.70141E

(-[ofx]

1.70141E+038 1.70141E+035 1.70141E4038 1.70141E+038 1.70141E
4447.84 4445.19 4448.39 9448.57 4445.96 4445.46 4449.64 2449
4450.49 4450.51 4450.47 4450.34 4450.24 4450.05 4449.5 4443.
4449.91 4449.5 4449.65 4449.51 1.70141E+038 1.70141E4035 1.7
1.70141E4038 1.70141E4038 1.70141E4038 1.70141E+038 1.70141E
1.70141E+4038 1.70141E4038 1.70141E4038 1.70141E+038 1.70141E
1.70141E+038 1.70141E4038 1.70141E4038 1.70141E+038 1.70141E
1.70141E+038 1.70141E+035 1.70141E4038 1.70141E+038 1.70141E
4997.63 4448.22 4445.48 445.54 4449.07 4445.56 4449.65 4443

I
e

<
For Help, press Fi.

The file generated is a standard text file and can be viewed using any word

processing package.

Export formats in the Map Analysis tool include Point (each record contains a Column Row Value triplet), Bare (each
record contains all of the values for one row of the grid starting at the top left corner), Surfer GS Ascii and ESRI
GridAscii that include header lines with the matrix of data (see below).

Bare Ascii no header lines—

B OGANICHATTER. TXT - WordPod e
File Edt View Inset Format Help

D= SR &l oo B
3 4E4030 3.411098 3,4E4030 3.4E/098 3.4L4020 3,4E4038 3.4L4030 3.4E+030 3.4L4090 3.4Es030 5]
SI4E4035 3.4E4038 3.4E4038 3. 4E4035 3.4E4038 344030 3.4EH038 3.4E038 3 4E4038 1.0255
1112427 1.12923 1.10346 1.08213 1.07269 1.0561 1.04113 1.31812 0.386357 0.958202
01538903 0.944052 0.574085 1.01385 3454038 3.4E038 3.4E4035 3.4E1038 3.4E4038 3.4E4038
3U4E4038 3.4E+035 3.4E4038 3.4E4033 3.4E4038 3.4E4098 3.4EH038 3.4E4038 3.4E4038 3451038
3I4E4035 3484038 3.4E4038 3.4E4035 3.4E4038 3.4E4098
3U4E4035 3.4E+038 3.4E4038 3.4E4035 3.4E4038 3.4E4038 3.4EH038 3.454038 3.4E4038 3454038
31484035 3.4E4038 3.4E4038 3. 4E4035 3.4E4038 3.4E4095 3. 4E4038 1.89671 195303 1.34981
113299 1,30182 1.23978 1.29775 1.27964 124913 1.21398 1.17566 1.13596 1.11893
1011732 111691 1.09275 1.0857 1.07775 106459 1.05163 1.02685 0985652 0.939918
0150791 0.921126 5.961873 1.0145 1.06202 1.10352 1.1536 3.4E4038 3.4E4038 3.454038
3I4E4038 3.4E4038 3.4E4098 3. 4E4035 3.4E4038 3.4E4030 3. 44038 3.4E+038 3.4E4038 3451038
3I4E4035 3.4E4038 3.4E4038 3 4E4035 3.4E4038 344035 3.4E4038 3.4E+038 3.4E4038 3454038
3I4E4035 3484038 3.4E4038 3.4E4030 3.4E4038 124459 1.91662 1.36260 1.40725 1.38684
1134552 1.31081 1.29771 1.29322 1.27261 1.23926 1.20481 1.15445 1.12085 1.1086

|

|7

For Hel

...Data separated by spaces and organized as rows in row-major matrix—contains no geo-referencing information.
File must contain a value for each cell location ordered left to right, top to bottom.

Surfer GS Ascii five header lines—

DSAA (ASCII)

66 64 (NCOLS NROWS)

-142.0357208 -142.0250092 (LON Low/High)

32.32790375 32.33668137 (LAT Low/High)

4440.64 4453.4 (Z Low/High)

...Data separated by spaces and organized as rows in row-major matrix (see Bare above)

ESRI GridAscii six header lines—

NCOLS 66

NROWS 64

XLLCORNER -142.0357208 (LON)

YLLCORNER 32.32790375 (LAT)

CELLSIZE 0.000162298

NODATA_VALUE 3.4E+038

...Data separated by spaces and organized as rows in row-major matrix (see Bare above)

SESSION 6. Exporting Data via File Tool

From the Main Menu select File > Export > Data to access the wizard for exchanging data.

Export Layers

Selectlayers) to expan |
] Veriz_Shallow_Conductivity

] eiis_Deen_Conductivity
Order_Ill_Sail Survey —

(]

1997_Yield_Volume

) 1997 _Yield_Mass Cancel
11997 field_Moisture =

[¥] 1996_Fall P
||

1996 Fal_pH
] 1996_Fall_NO3N
1199 Fall Zn

- res e =l

Select Al | DeSelect All |

Press the DeSelect All button then click on the boxes next to the
1997_Yield_Volume, 1997_Fall_P and 1997_Fall_K map layers. Press OKto begin the export.
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Export Map Set HE
Savein [ ) MapCale Data -] « @k B
[ Seipts
| %] Island DBF
Smalvile. DBF
File name:  Jaodata Save |
Save aslype: [DBase [dbi) - Concel |
C Help

Specify “CSV” as the type and Save the file. This procedure stores the file in the

—
ified 8/1/:
KB

2002 10:27 AM

el Comma Separa

tod Values File

Open - browse to the ...\MapCalc Data\ folder -> specify Text Files (*.prn,

Access Excel by clicking on Start > Programs > Microsoft Excel > File >
*.txt, *.csv) as the file type - click on

the AgData.csv file > and press the Open button.

The exported file containing the specified map layers will be opened in Excel.

Fle Edt Yiew Inset Fomat Tooks Data ‘Window Help -8 x
DEES8 8 +EE-T 9- &> -4 @i
Al - f _1997_Yield_Volume
A B € [ 0 [ E | F | 6 [
[1557_Yield1956_Fall_ 1956_Fall_Lat Lon Col Row =
295 15108 284513 323797 142033 1 i
64162 135107 270.395 3237797 142032 1 21
777576 121243 257705 323797 142032 1 2
944194 114252 251825 323797 142032 1 pi]
124531 11,3609 251573 3232097 142032 1 24
129.153 114498 250959 3232797 142032 1 2
138332 114074 248643 3232097 142032 1 %
140055 113075 245965 3232797 142031 1 7
113672 112426 244266 3232097 142031 1 =
552050 104822 231898 323797 -142031 1 P
105716 105442 232068 3232797 142031 1 Ell
129918 10223 226276 3232797 142031 1 El]
100586 219.554 323797 142031 1 2]
112 m . ES
1< i
Ready 4

In addition to .CVS format, there are several other standard export formats—

.DBF supports most spreadsheet and database software
.TAB supports MaplInfo desktop mapping software

.SHP supports ArcView desktop mapping software

.ACS supports Spatial Analyst software

.GRD supports Surfer software (GS ASCII).

SESSION 7. Seamless Data Exchange with Surfer

Select File> Export-> Send to Surfer-> Wireframe to automatically transfer the data and launch Surfer
provided it is installed on your computer...

DeSelect All I

Press the Deselect button, then check the Elevation map and press OK.
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;< — 2o dﬂ7

Surfer will be executed and the Elevation data automatically transferred.

SESSION 8. Seamless Data Exchange with Mapinfo

Select File> Export-> Send to MaplInfo> Wireframe to automatically transfer the data and launch Surfer
provided it is installed on your computer...

T Press the Deselect button, then check the 1996_Fall_P and 1996_Fall_K maps.
Press OK.

e im Teing tions Tasketng e [
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