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1.1.1.1. Introduction

Welcome to MapCalc

MapCalc is a grid-based data analysis program designed to enable you to visualize and
manipulate spatially related data. It builds graphic representations of data sets,
displaying data relationships across a grid layer or contour map. MapCalc offers an
extensive set of high-level spatial analysis tools in a Windows environment. These
advanced analysis tools make it easier for you to explore spatial relationships across
multiple data sets and perform complex analytical operations without learning a
programming language.

MapCalc creates map sets, in which each map layer represents one data set, or
spreadsheet column. You can view maps in two or three dimensions, with optional
gridlines, contour lines, and custom themes.

MapCalc exports maps to dBASE (.dbf), comma-delimited text (.csv), or MapInfo
Interchange (.mif), MapInfo table (.tab), ArcView Shapefile (.shp), or AgLeader 3000
(.tgt) formats. It accepts data files in MapInfo table (.tab) or ESRI shape (.shp) format,
and imports data from ESRI or Surfer grid (.grd) files.

You can save maps as graphic files in JPEG (.jpg), PNG (.png), bitmap (.bmp), or metafile
(.wmf,.emf) formats. Maps can easily be output to a printed report, or exported as.tab
or.shp files.

MapCalc Products

MapCalc is distributed in three different forms:

MapCalc Professional is the fully functional version which includes unlimited grid size
and all the tutorial materials on the MapCalc Learner CD.

MapCalc Learner is designed for students and those who want an inexpensive way to
learn about spatial analysis. The CD contains several tutorial resources.

MapCalc Learner – Academic is designed for instructors. It offers two CDs, and provides
a wide selection of teaching resources.
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Analysis Tools

MapCalc ’s powerful modeling capabilities are divided into two classes—spatial statistics
and spatial analysis. Spatial statistics tools investigate statistical patterns and
relationships among maps. They include:

• Descriptive statistics

• Normality tests

• Point density maps 

• Geographic trend analysis

• Spatial interpolation

• Spatial autocorrelation

• Residual analysis

• Error mapping

• Coincidence statistics

• Change surfaces

• Comparison tests

• Spatial correlation and dependency

• Multivariate regression

• Clustering

• Map similarity

Spatial analysis tools derive new maps based on spatial context, patterns, surface
configuration, proximity, connectivity and flows. They include:

• Geographic search

• Slope and aspect

• Optimal path

• Nearby neighbor summary

• Narrowness

• Confluence surfaces

• Weighted proximity analysis

• Visual exposure

• Local, regional & map-wide overlay
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• Edge, shape and pattern characterization

• Logical, ranking, rating and mathematical combination

• Probability and propensity analysis

Getting to Know MapCalc

User’s GuideUser’s GuideUser’s GuideUser’s Guide

The MapCalc User’s Guide introduces you to all of MapCalc’s functions and the primary
operations of MapCalc, such as creating map sets, importing data, exporting data,
printing reports, and using the advanced map analysis tools. This level of information is
adequate for those who are skilled in spatial statistics and analysis, but need to reference
how to perform a particular function in MapCalc.

You should be familiar with common Windows operations before using MapCalc , such as
moving files or folders, opening or closing programs, installing or uninstalling programs,
mouse operation, and using windows and dialog boxes. Red Hen Systems does not offer
technical support for operating Microsoft® Windows.

Note that some sections apply only to a particular MapCalc product. These sections are
marked with the appropriate product name, for example MapCalc Professional.

Other Learning ResourcesOther Learning ResourcesOther Learning ResourcesOther Learning Resources

You must be familiar with spatial analysis to properly apply and understand the
MapCalc analysis tools and the maps you can create with them. Since spatial analysis
and spatial statistics can be challenging topics, a set of educational resources are
included on the MapCalc CD.

The Precision Farming Primer contains a wealth of information on spatial statistics
applied to site-specific agriculture. The explanations of statistical concepts are extremely
helpful for people in any industry.

Map Analysis: Uncovering Spatial Relationships Through Grid-Based Modeling is
another online book that will help you further explore many analytical concepts you can
apply with MapCalc.

Additionally, MapCalc Learner – Academic comes with a selection of materials on a
second CD, for instructors to use in designing lesson plans and workshops.

Online HelpOnline HelpOnline HelpOnline Help

 Many dialog boxes in MapCalc have a question mark button in the upper right corner
next to the window controls. To find out about a dialog box option, click the question
mark, then click the part of the dialog box you need more information about. This is the
quickest way of getting an answer about a specific object in a dialog box.
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If you need more information about a dialog box, click the Help button  to
open the help topic for the current task.

The help file doubles as an online book for reference as well as task-based instructions.

Note that some sections apply only to a particular MapCalc product. These sections are
marked with the appropriate product name, for example MapCalc Professional.
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2.2.2.2. Getting Started

Installation

To install MapCalc or supporting programs offered on the CD, insert the CD into your
CD drive. Select Install Programs, then choose the program to install from the list on
screen.

If the MapCalc installation program does not start automatically, select Run from the
Windows Start menu, then enter D:\setup.exe (substitute the correct CD drive letter
if not the “D” drive).

Start MapCalc by selecting it in the Windows Start menu.

Registration

"""" IMPORTANT: MapCalc must be registered within the trial period. If the trial period
is exceeded before the program is registered, MapCalc will no longer start.

The Registration Wizard assists you with entering your user information, serial number,
and release code (supplied with the serial number). This Wizard opens automatically
when you start MapCalc. If you choose to cancel the process when the program starts,
you can complete it later by selecting Help>Register Software.
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3.3.3.3. Creating, Modifying, and Saving Map
Sets

Creating a New Map Set

The Map Set Creation Wizard helps you create a new map set if you have data in.tab
or.shp files, and you want to interpolate the data across the map.

Under the following two conditions you should not use the Map Set Creation Wizard:

1 If you need to import data into an existing map set from a gridded file (bare, ESRI grid,
or Surfer grid), then you should close this wizard, open the existing map set, and select
Map Set>Map Analysis to use the Import tool.

2 If you need to import data into an existing map set from a table or shapefile (.tab or.shp),
then you should close this wizard, open the existing map set, and select Map Set>Add
New Layers.

"""" Note: MapCalc Learner and MapCalc Learner– Academic accept only spatial data
recorded in the WGS84 datum.

Select File>New or click the New  toolbar button. The Map Set Creation Wizard
opens and leads you through the following steps for map set creation.

Specifying Boundary and Grid Cell LengthSpecifying Boundary and Grid Cell LengthSpecifying Boundary and Grid Cell LengthSpecifying Boundary and Grid Cell Length

• Specify a boundary file or fit the grid to the extents of the data. This step sets up the
size of the grid. You can use a boundary file to define the grid perimeter. Use the
Browse button to select a.tab or.shp file.

If you do not have a boundary file, MapCalc can use the extents of the data for the
grid boundary.

• Specify the grid cell length. The larger the grid cell size, the lower the number of cells
in the grid. Changes in grid cell size have a noticeable impact on processing time. If
you notice very slow processing, you may need to increase the size of grid cells.

"""" Note: MapCalc Learner allows a maximum grid size of 100 columns x 100 rows. It is
possible to exceed the maximum number of grid cells, depending on the grid cell
length you enter. If the data set you select in Step 2 will generate a grid that exceeds
the maximum, MapCalc Learner will prompt you to return to this step and increase
the grid cell size.
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Adding Data SetsAdding Data SetsAdding Data SetsAdding Data Sets

""""  Note: See below to create an empty map set and import existing data layers.

1 Click Add File to choose.tab or.shp files. Available data sets in the selected files are
listed on the right. If a file contains point and region (polygon) data, the Use Centroids
box is checked. If you clear the check box, the list shows all data columns, both numeric
and character. For point data, only numeric values can be used. For polygon data, you
have two options:

• Treat polygons as points by using centroids (geographic centers) of the polygons as
points.

• Use polygon data as-is, for instance to identify categorical distinctions. In this case,
no interpolation is done, and the grid cells that lie under the polygons will be
assigned the polygon data value. Because there is no interpolation in this type of
layer, character (discrete) values such as "sandy loam" or "clay" in the original data
can also be used.

2 Check the boxes for the data sets you wish to use.

Creating an Empty Map SetCreating an Empty Map SetCreating an Empty Map SetCreating an Empty Map Set

Use this option when you want to import data files, but you do not have an existing map
set into which to import the data.

Click the Create Empty Map Set button. The Grid Parameters dialog prompts you to
enter basic information from which to construct the grid.

• If you selected a boundary file and cell length, MapCalc has all the information it
needs. The empty map set is created.

• If you selected to construct the grid based on the extents of the data, then you must
enter latitude and longitude coordinates for the lower left corner of the grid. You
must also specify the size of grid cells, and number of columns and rows. This
information will be based on the data layers you plan to import.

After the empty map set is created, you can import data by either of these methods:

1 If you need to import data from a gridded file (bare, ESRI grid, or Surfer grid), then
select Map Set>Map Analysis to use the Import tool.

2 If you need to import data from a table or shapefile (.tab or.shp), then select Map
Set>Add New Layers.
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Setting Interpolation ParametersSetting Interpolation ParametersSetting Interpolation ParametersSetting Interpolation Parameters

1 Inspect a variogram for each data set if necessary. If you do not know whether your
continuous data set exhibits spatial dependence, view a variogram. Highlight a data set,
then click Variogram.

If the variogram shows that a data set does not exhibit spatial dependence, then the data
is not suitable for interpolation. Click Back to return to Step 2 and remove that data set
from the list.

2 Select interpolation options for each data set. For each selected data set, choose whether
the grid values will be interpolated by the inverse distance method or by kriging. For an
overview of spatial interpolation topics and further discussion of the available methods,
refer to the educational resources provided on the MapCalc CD.

• If you choose the inverse distance method, you can specify the number of nearest
points or a search radius to use in determining each value. If you clear both of these
options, MapCalc uses every data point in the interpolation. If you select Skip
Zeros, MapCalc will not substitute another point, but will simply skip any zero
encountered in the search.

• If you choose kriging, you must select a suitable model to which the variograms are
fitted. MapCalc offers spherical, Gaussian, and exponential. Also enter the values for
the sill, nugget, and range, based on the variogram you created in Step 1.

3 To specify units, click on the ellipsis next to the Units box to open the Select Unit dialog
box. MapCalc utilizes hundreds of different unit types. Click on the data category on the
left side, then select from the unit list on the right. When finished, click OK to return to
the Map Set Creation Wizard.
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"""" Note: No options need to be set when using discrete (polygon) data, such as area
labels. There is also no need to inspect a variogram of such data. MapCalc uses the
value assigned to the polygon over the appropriate grid cell, with no interpolation.

4 Click Finish to create maps. A separate map window is created for each data set, map-
specific menus appear, and the Map Toolbar is activated.

Adding Layers to the Current Map Set

MapCalc features a Wizard that helps you add new data to an existing map set. This
Wizard is identical to the Map Set Creation Wizard described in the previous section,
except that you do not need to specify a boundary for an existing map set so the first
screen is omitted.

"""" Note: MapCalc Learner and MapCalc Learner – Academic accept only spatial data
recorded in the WGS84 datum.

"""" Note: If you need to import data from a gridded file (bare, ESRI grid, or Surfer grid
formats) without interpolation, select Map Set>Map Analysis and use the Import
tool. For more information, see Import in Chapter 9 for more information.

Select Map Set>Add New Layers to begin. The Wizard leads you through the steps to
add new map layers from files in.tab or.shp format. For more information, see Adding
Data Sets and Setting Interpolation Parameters in the previous section.

Importing Data

You can import data when you need to open map layers from data sets contained in.grd
files, and when you do not wish to interpolate the layer.

Saving Map Sets

Saving a Map SetSaving a Map SetSaving a Map SetSaving a Map Set

1 Select File> Save or click the Save  toolbar button.

2 If necessary, use the drop-down list to select a different folder.

3 If you are saving a new map set, enter a name in the File name box.

4 Click Save.
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Saving a Map Set as a New Map SetSaving a Map Set as a New Map SetSaving a Map Set as a New Map SetSaving a Map Set as a New Map Set

You can save a copy of the current map set with a new name. You should do this when
you want to make changes or additions to a map set, while keeping the original map set
intact.

1 Select File>Save Map Set As…

2 If necessary, use the drop-down list at the top to select a different folder.

3 Enter a name in the File name box.

4 Click Save.

Opening and Closing Map Sets

Opening a Map SetOpening a Map SetOpening a Map SetOpening a Map Set

You can open.rgs files in MapCalc.

1 Select File>Open.

2 If necessary, use the drop-down list to locate the folder that contains the desired file.

3 Double click on the file name

-or-

Click on the file name, then click Open.

Closing a Map SetClosing a Map SetClosing a Map SetClosing a Map Set

Select File>Close or click the Close  toolbar button. You will be prompted to save
the map set if you have made any changes.
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Exporting a Map Set

MapCalc allows you to save the current map set in a different file format. You can export
the map set in these formats:.tab,.shp,.csv,.mif, or.tgt.

1 Select File>Export.

2 If necessary, use the drop-down list at the top to select a different folder.

3 Enter a name in the File name box.

4 Select a file format from the Save as type drop-down list.

5 Click Save.
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4.4.4.4. Setting Program Defaults

Select View>Options to open the Default Options dialog box.

This dialog box enables you to specify the global settings of MapCalc , including the
appearance of maps, reports, and graphs, as well as what happens when the program
starts.

Setting Startup Options

The General tab contains selections for how the program starts.

Select What MapCalc Should Open

The Quick Start selection tells MapCalc whether you want to:

• Open the program with the Map Set Creation Wizard

• Open the program with the last-used map set

• Open the program with the Load Map Set dialog box

• Open the program with a blank screen

You can also select whether to display the Quick Start selection dialog and the splash
screen every time the program opens.

Set Default Units

Set the default distance and area measurements.

Setting Default Map Display Options

The Map Display tab contains selections for how all maps are displayed. Individual map
properties can be changed in the Map Properties dialog box.

3D View

Toggles between 3D and 2D view.

Contour Selections

• Layer Contour toggles display of ranges thematically over the 3D layer, using the
settings in the Shading Manager.

• Layer Contour Lines toggles lines between ranges on the contour map.
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• Floor and Ceiling Contours toggle a 2D contour map of the 3D layer on the floor or
ceiling.

• Floor and Ceiling Contour Lines toggles contour lines on the floor or ceiling.

X,Y Mesh

For 3D maps only. Toggles the display of an X,Y grid over the map. The display options
allow you to set whether to show rows, columns, or both. You can also enter a value to
show every “nth” row or column.

Use Cells

Assigns one value to each cell, rather than interpolating across cells. This results in a
grid of squares, each square having a single value. The visual effect on the map is that
each grid cell is themed with a single color.

Set View Angle

For 3D maps only. Use the up and down arrows to adjust values for the tilt and rotation.
Click Apply to see the result while the dialog box is open. (Do not click Apply to Open
Maps unless you want all changes made to all maps.)

Setting Default Map Title Properties

The Map Title tab contains selections for how all map titles are displayed. Individual
map properties can be changed in the Map Properties dialog box.

Show Title

If you do not want a title to appear on the map, clear the Show title check box.

Select Font and Background Color

The title will appear on printed reports and saved map images.

• Click the Font button to open the Windows font dialog. Choose a font, size, and color.

• Click the Color button to open the Windows color dialog. Choose a color for the
background area around the map title.

Select Border

There are a variety of border styles to choose from in the drop-down list. The border
width can be adjusted from 1 to 9 pixels.
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Setting Default Map Legend
Properties

The Map Legend tab contains selections for how all map legends are displayed.
Individual map properties can be changed in the Map Properties dialog box.

Select Font and Background Color

The legend will appear on printed reports and saved map images.

• Click the Font button to open the Windows font dialog. Choose a font, size, and color
for the units shown in the legend.

• Click the Color button to open the Windows color dialog. Choose a color for the
background area around the legend.

Show Legend

Toggles display of the legend in the map window.

Set Position

The legend can be displayed on any side of the map.

Show Units

Toggles display of units on the legend.

Select Border

There are a variety of border styles to choose from in the drop-down list. The border
width can be adjusted from 1 to 9 pixels.

Setting Default Plot Cube Properties

The Map Plot Cube tab contains selections for how all maps are displayed. Individual
map properties can be changed in the Map Properties dialog box. Except as noted, plot
cube properties are visible when you view maps in 3D mode.

Scale

MapCalc determines a scale for each map based on the data it contains. Scale can be set
in the Map Properties dialog box for individual maps by selecting Map>Properties.

Show Grid Lines

Toggles display of lines perpendicular to the Y axis, which cross the major scale tick
marks.

Show Units

Toggles display of map scale units.
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Select Colors

• Click the Cube Color button to set the color of the lines (axes) that make up the
outline of the cube.

• Click the Cube Interior button to set the fill color of the cube.

• Click the Background Color button to set the background color for the map window
(also visible in 2D view).

Font Size

Enter a number in the blank or use the arrow buttons to set the font size for range
intervals displayed on the axes.

Setting Default Scatter Plot Display
Options

The Graph Scatter tab contains selections for how all scatter plots are displayed. To
change properties for individual graphs, right-click in the graph window and select
Properties.

Select Symbol Style

• Click the Color button to open the Windows color dialog, and pick a color.

• Click the Style list to choose from a selection of graph markers.

• Enter the desired font size for the graph markers in the Size box.

Select Regression Line and Choose Style

• The Show Regression Line check box is selected by default. Clear the check box if you
do not want to see a regression line on scatter plots. If the line is not shown, the
regression equation is not shown.

• Click the Color button to open the Windows color dialog, and pick a color.

• Enter the desired width for the regression line in the Width box.
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Setting Default Histogram Display
Options

The Graph Histogram tab contains selections for how all histograms are displayed. To
change properties for individual graphs, right-click in the graph window and select
Properties.

Select Pattern Style

• Click the Color button to open the Windows color dialog, and pick a fill color.

• Click the Pattern list to select a fill pattern. N means no pattern.

Select Histogram Type

• Bars: you can view the data in discrete ranges using bars. The height of the bars
represents the area contained in each range.

• Area: you can view the data in a continuous graph. The height of the graph at any
point represents the total area corresponding to the variable.

Setting Default Graph Title Options

The Graph Title tab contains selections for how titles are displayed in graph windows. To
change properties for individual graphs, right-click in the graph window and select
Properties.

Show Title

If you do not want a title to appear on the graph, clear the Show title check box.

Select Font and Background Color

The title. will appear on printed reports and saved map images.

• Click the Font button to open the Windows font dialog. Choose a font, size, and color.

• Click the Color button to open the Windows color dialog. Choose a color for the
background area around the map title.

Select Border

There are a variety of border styles to choose from in the drop-down list. The border
width can be adjusted from 1 to 9 pixels.
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Setting Default Graph Footer Options

The Graph Footer tab contains selections for how footers are displayed in graph windows.
To change properties for individual graphs, right-click in the graph window and select
Properties.

Show Footer

The footer area contains the regression equation for scatter plots. If you do not want a
footer to appear on the graph, clear the Show footer check box.

Select Font and Background Color

The title will appear on printed reports and saved map images.

• Click the Font button to open the Windows font dialog. Choose a font, size, and color.

• Click the Color button to open the Windows color dialog. Choose a color for the
background area around the map title.

Select Border

There are a variety of border styles to choose from in the drop-down list. The border
width can be adjusted from 1 to 9 pixels.

Setting Default Graph Axes Options

The Graph Axes tab contains selections for how axes are displayed in graph windows. To
change properties for individual graphs, right-click in the graph window and select
Properties.

Select Colors

• Click the Axes button to set the color of the X,Y axis lines.

• Click the Plot Interior button to set the fill color of the graph.

• Click the Plot Background button to set the background color for the graph
window.

Font Style and Size

Click the Font button to open the Windows font dialog box. Choose a font, size, and style
for the numbers displayed at major tick marks along the axes.

Show Grid Lines

Grid lines are dotted parallel lines forming a reference grid in the background of the
graph area. They are placed at major tick marks. Clear the check box if you do not want
grid lines displayed.
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Setting Default Report Options

The Report tab contains selections for printed report layout defaults. To change
properties for individual report printing, click the Options button in the Report Printing
dialog box.

Edit the Report Header and Footer

If you do not want a header to appear on printed reports, clear the Show Header check
box. You can enter Header Left Text to appear on the upper left side of the report, and
Header Right Text to appear on the upper right side of the report.

Click the Font button next to each entry to set the font, color, size, and other attributes
for each side of the header area.

Select a Logo for Reports

To use your own logo or other graphic image, click the Load button. Locate the logo and
click Open. MapCalc accepts many graphic formats including.jpg,.bmp, and.wmf.

The image is scaled and centered in the header area of the report.

Select Footer Options

If you do not want a footer to appear on printed reports, clear the Show Footer check box.
You can choose to show the date the report was generated, the map set name, and the
page number. Multiple page reports are printed in the order shown in the Report
Printing dialog box.

Setting Default Map Analysis Options

The Analysis tab contains optional settings for the Map Analysis tools.

Quick Execute Analysis Statements

Select this option if you want each map analysis command to execute as soon as you close
the tool dialog box. As soon as the command line is entered in the Map Analysis dialog
box, the analysis will run.

Display Analysis Results in Workspace Window

Each map analysis tool normally outputs a resulting map in a separate window. If you
select this option, all resulting maps will be displayed in one window. Each map is
replaced by any subsequent analysis operation.

Enable Macro Creation

If you want to create and save tutorial scripts for others to use, MapCalc provides a set of
macro creation tools. These include tools for displaying your notes on the screen to
accompany specific steps, displaying the online help topics for analysis tools, pause the
script and prompt the user to continue, or output data descriptions of map layers.
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5.5.5.5. Working With Maps

Managing Layers

Select Map Set>Manage Layers, or click the  toolbar button to open the Manage
Layers dialog box. This dialog box assists you in selecting maps to view, rename, or
delete from the map set.

You can select one layer at a time in the list of map layers.

Viewing Maps

Select a map in the list, then click View (you can also double-click the map name). This
opens the selected layer in a new window and places it over other windows for viewing. If
the layer you select is already open, the map window will move in front of any other
windows. To create a copy of any map, select the layer and click Clone View.

Renaming Maps

Select a map in the list, then click Rename. You are prompted to enter a new name for
the selected layer.

Deleting Maps

Select a map in the list, then click Delete. This removes a selected layer from the map
set. This does not alter or delete anything from the original data file. The map is simply
removed from the current map set. If you want to restore the map layer later, use the
Add New Layers command.

More Tips for Viewing MapsMore Tips for Viewing MapsMore Tips for Viewing MapsMore Tips for Viewing Maps

• If a map window is open in the current map set but is hidden by other map windows,
you can bring it to the front by selecting it from the Windows menu.

• To add a new map layer to the current map set, select Map Set>Add New Layers
and follow the instructions in the Wizard.

• To adjust the scale or angle at which you view the map, try using the Rotate, Pan,
and Zoom tools to adjust the viewing angle, map position in the window, and the
zoom. Rotate does not apply to 2D maps.

• To use the Rotate, Pan, or Zoom Out tools, select the tool then hold down the primary
mouse button while sliding the mouse over the map. To use the Zoom In tool, select
the tool then drag a box around the area for which you want a closer view.

• To switch between 2D and 3D views, select Map>3D or click the 3D View 
button. 3D views offer many different viewing options, including floor and ceiling
contour lines and the ability to change the view angle.
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• To change the appearance of a map, select Map>Properties and adjust the settings
in the Map Properties dialog box.

• To change the data type, click the Data Type  toolbar button to toggle between
discrete and continuous data. This may be necessary after using some of the Map
Analysis tools, for instance, if you used analysis tools to convert an original map of
continuous data to a map of zones with discrete values.

Inspecting Data

To view the data for the entire map set, select View>Data Inspection. This opens a
spreadsheet window that shows the value for every layer at any point. Just move your
Select tool over any map to see how this works.

A shortcut to open the Data Inspection window is to double-click on any map.

Hover the Select tool over a point on any map to see the data value for that grid cell in a
popup window.

Graphing

MapCalc can create a scatter plot and a histogram to help you get a quick overview
certain statistical behavior in your data. A scatter plot can indicate correlation between 2
parameters. A histogram shows how data values are distributed.

Note: There is also a histogram displayed in the Shading Manager dialog box, which
shows divisions based on standard deviation or equal ranges.

Create a Scatter PlotCreate a Scatter PlotCreate a Scatter PlotCreate a Scatter Plot

1 Select Map Set>New Graph>Scatter Plot.

2 In the Scatter Plot Variables dialog box, select the map layers to plot on the X and Y
axes. The data in these map layers is graphed, and a linear regression equation derived.

The correlation coefficient, R² is shown as a percentage. It is an indicator of whether the
two parameters are related. R² = 100% indicates the best-fitted lines for each parameter
coincide completely.

A Graph menu is available when a scatter plot or histogram is the active window. You
can set the properties for the current graph by selecting Graph>Properties.

Default scatter plot display settings are found in the Default Options dialog box.
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Create a HistogramCreate a HistogramCreate a HistogramCreate a Histogram

1 Select Map Set>New Graph>Histogram.

2 In the Histogram Variable dialog box, choose a map layer then click Ok.

A histogram shows how data values are distributed in intervals, plotting the number of
data values found in each range, or interval. For instance, a histogram of elevation would
show how many acres lie within each elevation range. Histograms are available for
continuous data.

A Graph menu is available when a histogram or scatter plot is the active window. You
can set the properties for the current graph by selecting Graph>Properties.

Default histogram display settings are found in the Default Options dialog box.

Setting Current Map Properties

Maps are created with default properties that are set in the Default Options dialog box.
After you create maps, you can set many properties individually.

To open the Map Properties dialog box, select Map>Properties. The title bar displays
the name of the map for which you are setting properties (this is the map in the active
window).

"""" Note: Many settings in the Map Properties dialog box are identical to those in the
Default Options dialog box. Refer to Chapter 4 for descriptions of tabs and options,
except as listed below.

After you select the properties for the current map, you can use the buttons at the bottom
of the dialog box to:

• Apply to see the changes in the current map while keeping the dialog box open.

• Apply to Open Maps to set these properties for all of the open maps.

• Use as Map Defaults to set these properties as the program defaults for all new
maps.

Setting Map Title PropertiesSetting Map Title PropertiesSetting Map Title PropertiesSetting Map Title Properties

The Title tab contains title display options for the currently selected map. This tab is
identical to the Title tab in the Default Options dialog box, except for the following:

Use Default

If you wish to enter a new title, clear the Use Default check box. The default setting
displays the map name as the title. You can type in the entry blank when Use Default is
not checked.
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Converting Map UnitsConverting Map UnitsConverting Map UnitsConverting Map Units

The Units tab enables you to change the units used in the currently selected map.

Convert Units

1 Click the ellipsis button (…) to open the Select Units dialog box.

2 Choose a category, then select from the unit types in that category.

3 Click Ok to close the Select Units dialog box.

4 To convert units click Convert.

Viewing DataViewing DataViewing DataViewing Data

The Data tab displays the data contained in the currently selected map in a spreadsheet
format.

Scroll to View Grid Values

The datavalues for each grid square are shown as a spreadsheet in the window. Use the
scroll bars to move through the spreadsheet. Raw, or unconverted, data values are
shown.

Rows correspond to Y distance on the grid, and columns correspond to X distance on the
grid. The data value corresponds to Z distance when the map is viewed in 3D mode.

You can also view the data contained in the entire map set by selecting View>Data
Inspection.

Viewing Layer InformationViewing Layer InformationViewing Layer InformationViewing Layer Information

The Statistics, Values, Equation, and Source tabs display in-depth information about the
currently selected map.

View Statistics

The Statistics tab displays common statistics if the currently selected map contains
continuous data. You can perform any other necessary calculations using the Map
Analysis tools.

View Values

The Values tab displays categorical data types and map coverage information if the
currently selected map contains discrete data.

View Equation

If this map was generated as a result of an equation calculated by any of the Map
Analysis tools, the equation is shown on the View Equation tab.

View Source

The View Source tab displays more information about how the current map was created,
and defining parameters such as grid size and the spatial coordinates at the origin.
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Using the Shading Manager

The Shading Manager dialog box helps you customize the ranges and color theme
applied to any map. It also saves and recalls your custom themes.

To open the Shading Manager, select Map>Shading Manager or click the  toolbar
button. You can also open the Shading Manager by double-clicking on the legend in a
map window.

The Shading Manager dialog box offers different settings depending on whether the
selected map contains continuous or discrete data. For discrete data, there are no tabs on
the right side of the dialog box (Range Controls section). The Range Display section
shows only the category, count, and color for each data type.

Range Display Section

The Range Display section on the left side of the Shading Manager contains the following
columns for continuous data:

• minima and maxima for the current data ranges

• count of cells, distributed by range

• acres and % area for each range

• color used in map theme

Range Controls Section

The Range Controls section on the right side of the Shading Manager contains four tabs
if the selected map contains continuous data:

• calculations for changing the range calculation method

• statistics for reviewing statistical data about the selected map

• histogram for reviewing data distribution by range or standard deviation for the
selected map

• templates for saving or recalling themes

Setting Map RangesSetting Map RangesSetting Map RangesSetting Map Ranges

Selecting a Calculation Mode

In the Shading Manager, select the Calculations tab. Choose how the ranges will be
calculated by selecting a method in the drop-down box.

If you choose Custom Min/Max/Increment you can manually input a minimum value,
and a maximum value or an incremental increase value.

"""" Note: the entry for Min is used as the upper limit of the lowest range, and the entry
for Max is used as the lower limit of the highest range.
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If you choose User Defined ranges, you can click directly in the range column on the
left side of the Shading Manager and make changes.

"""" Note: You can set only the lower limits on the ranges, except for the highest range,
which will accept an upper limit entry.

Other range calculation methods include +/- 1, 2, or 3 standard deviations, equal
ranges or equal counts.

Changing the calculation method does not change the shape of the map; the map is
created using the actual data points and interpolated values to generate the layer.
Changing the calculation method does change the way the theme is displayed on the
grid. See Using Colors & Ranges in Data Analysis for more information.

Setting the Number of Ranges

Choose up to 100 ranges from the drop-down list on the Calculations tab.

Setting the Rounding Value

Select from the rounding values in the drop-down list on the Calculations tab.

Setting Map ThemeSetting Map ThemeSetting Map ThemeSetting Map Theme

Selecting Colors

Change colors by clicking on the desired color to activate the Windows color palette.
Select the new color and click Ok.

A color range may be interpolated by unlocking the colors (see below), selecting the color
for the highest range, then selecting the color for the lowest range. The intermediate
ranges will be automatically determined.

The methods by which the colors are determined (color interpolation method) are RGB
(red, green, and blue) and HSV (hue, saturation, and value). Select the desired color
interpolation method on the Calculations tab on the right side of the dialog box.

Setting Locks on Colors

Toggle all color locks by clicking on the column heading.

Toggle individual color locks by clicking On or Off in the Lock column.

To interpolate colors between the lowest and highest ranges, only the lowest and highest
range colors should be locked. Another common method of color distribution uses a locked
midrange, with intermediate colors interpolated between the low, middle, and high
ranges.

"""" Note: when switching between RGB and HSV color interpolation methods, only
unlocked colors are affected.
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 Using Colors & Ranges in Data Analysis Using Colors & Ranges in Data Analysis Using Colors & Ranges in Data Analysis Using Colors & Ranges in Data Analysis

You can use the Shading Manager to view your maps in many different ways to look for
different relationships in the data. Using different themes and numbers of ranges can
help you visualize and discover new relationships in data sets.

The default settings for map creation are:

ranges: 7

colors: ranging from red to yellow to green (colors locked on minimum, maximum, and
midrange)

calculation mode: +/- 1 standard deviation

Examples

• Jane wants to see only the far outliers of the data. She can select 3 for the number of
ranges, set the colors desired, and change the calculation mode to +/- 2 or 3 standard
deviations.

• John has created a difference map (i.e. 1991Nitrogen – 1995Nitrogen). He sets the
range from -100 to 100 to center the theme on zero.

There are countless ways to display data layers, and many of your options can be
adjusted to reflect your own personal preference. A little experimentation will show you
how to view each layer to best visualize the results you are searching for.

 Viewing Statistics Viewing Statistics Viewing Statistics Viewing Statistics

Select the Statistics tab in the Shading Manager dialog box to view statistical values for
the data set, including minimum, maximum, mean, standard deviation, and variance.

Viewing a HistogramViewing a HistogramViewing a HistogramViewing a Histogram

Select the Histogram tab in the Shading Manager dialog box to view a graph showing the
distribution of the data. This can be helpful in determining the minimum and maximum
values to include in grid calculations. The histogram quickly shows which values
correspond to the highest and lowest numbers of points.

Viewing Range Bars

Select to view bars overlaid on the graph to show the data separated by:

• ranges as defined by the calculation method on the Calculations tab

• divisions of standard deviation, where the mean is shown as a blue line.
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Saving a TemplateSaving a TemplateSaving a TemplateSaving a Template

You can create a custom template to recall for theming other maps.

1 Set the ranges as described previously in Setting Map Ranges.

2 Set the theme as described previously in Setting Map Theme.

3 On the Template tab of the Shading Manager dialog box, click Save. Enter a name, then
click OK.

-or-

If you wish to start from an existing template and then make changes, click Save As.
Enter a name, then click OK.

Selecting a TemplateSelecting a TemplateSelecting a TemplateSelecting a Template

Choose a template from the list on the Template tab of the Shading Manager dialog box,
choose. The template is applied to the Shading Manager settings.

You can click Cancel to close the Shading Manager dialog box and leave the original
template unchanged.
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6.6.6.6. Printing Reports

MapCalc provides customizable reporting capabilities, along with prepared print formats
to choose from. You can print a report for any map(s) in the currently open map set.

1 Select File>Print or click the  toolbar button.

2 Select the maps to print. You can use the arrow buttons between the Map List and the
Selected List to move maps back and forth. Move the desired maps into the Selected List.
The single arrows move one selected map, and the double arrows move the entire list.

You must click the Selected button beneath the Map List to use the arrows for selecting
maps.

To sort selected maps in a different order, use the Move Up and Move Down buttons
beneath the list. Reports will print in the order shown.

3 Select the report style. Enter the number of columns and rows per page. The blue image
of a page next to the column and row entries shows you the layout you have chosen. Also
specify landscape or portrait printing, and whether to show histograms and statistics.

4 Enter a header, footer, and logo if desired. Click the Options button if you wish to
customize the report (see Customizing Reports below for more information).

5 Click Print.

Customizing ReportsCustomizing ReportsCustomizing ReportsCustomizing Reports

Click Options in the Report Printing dialog box to add page header information, change
fonts, or add a logo to your printed reports.

Editing the Report Header and Footer

Enter Header Left Text to appear on the upper left side of the report, and Header Right
Text to appear on the upper right side of the report.

Click Font next to each entry to set the font, color, size, and other attributes for each
side of the header area.

Select footer options by checking the boxes for the Date, Map Set Name, or Page Number
as desired.

Selecting a Logo for Reports

To use your own logo or other graphic image, click Load. Locate the logo and click Open.
MapCalc accepts many graphic formats including.jpg,.bmp,.ico,.emf, and.wmf. The image
will be scaled and centered in the header area of the report.

You can set defaults for these properties in the Default Options dialog box.
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7.7.7.7. Using Images in MapCalc

Image registration available in MapCalc Professional. Registration is a process of
associating a small number of reference GPS data points with corresponding points on a
raster image. This process creates a.tab file containing a small set of control points
identifying specific locations on the image. The file is saved as image.tab in the MapCalc
Data folder.

The reference GPS data points are copied from an existing.tab file, such as a file of GPS
reference points or a field boundary. The raster image is a photograph of the same
location. MapCalc accepts raster images in these formats:

Windows or OS/2 bitmap,.bmpWindows Metafile,.wmf

Tagged Image File Format,.tif Zsoft,.pcx

JPEG,.jpg Portable Network Graphic,.png

TARGA,.tga Sun Raster,.ras

Adobe Photoshop,.psd Mac PICT,.pct

Registration of a raster image is a prerequisite step for transforming the image into an
importable format for MapCalc. If you want to add an image to your map set, first
register the image, then transform it into a complete set of MapInfo table files.
Instructions for transforming registered images are at the end of this chapter.
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The Image Registration Window

To open the Image Registration window, select File>Image Registration.

File Menu

Use the File Menu to close
the Image Registration
window.

Image Menu

Use the Image Menu to
open the raster image, set
zoom level, and "apply"
(overlay) the image with
the selected.tab file after
you add control points.

Map Menu

Use the Map Menu to open
the.tab file containing the
GPS reference points, move
or zoom the map in the
window, or add control
points. You can use the
Select pointer to choose
point features and convert
them to control points
(lines or polygons cannot
be converted to control
points).

Help Menu

Use the Help menu to open online help for Image Registration.

Control Points Information

The top area of the window contains a table that displays information about the control
points you place on the map and the image. For the image control points, you see the X,Y
coordinates. For the map control points, you see the latitude and longitude.

Control Point Actions

Select to add a new control point, edit or remove a selected control point, or remove all
control points.

Image Toolbar

Use this toolbar to open a raster image, set the zoom level, create control points, and
apply the image to the map.
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Image Window

The raster image is displayed in this area.

Map Window

The map layer with the GPS reference points is displayed in this area. This is also where
you will check the accuracy of your control points after you use the Apply command.

Map Toolbar

Use this toolbar to move the map in the window and set the zoom level, center the map
on the cursor, add control points to the map, or open the Layer Manager to add or remove
map layers.

Registering an Image

1 Click the Image  button and select your raster image.

2 (This step is optional - you can manually enter reference coordinates if you like.)

Click the Layer Manager button , then click Add to select the *.tab file containing the
GPS reference points.

3  (This step is optional - you can manually enter reference coordinates if you like.)

a Click the Control Point button  on the Map toolbar, then click on a map reference
point. Click OK in the Control Point information window to add the map point
information to the table.

b Click New to add a new control point, then click the map at a reference point. Repeat
to add at least two more control points.

4 To add control points to the map:

a Click the Control Point  button on the Map toolbar.

b Click on the map where you want to place the point. Click OK in the Control Point
information window to add the map point information to the table. Repeat to add at
least two more control points.

2 To add control points to the image:

a Click the Control Point  button on the Image toolbar.

b If you placed control points on a map in the map window, select a point in the list at
the top. If not, continue with the next step.

c Click on the image at the location to place the control point. If you do not have map
reference points, then enter the reference coordinates. Click OK in the Control Point
information window to add the image point information to the table. Repeat to add
the remaining control points.
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3 Check the results:

a Click the Apply  button on the Image toolbar.

b The image is displayed in the map window, with the reference map overlaid.

c If the control points are not well matched, distortion occurs in the map layer. To

remove the image from the map window and try again, click the Undo  button.
See how to edit control points in Step 6.

d If the control points are well matched, the registration process is finished.

4 If you need to edit control points:

a Click the Control Point  button on the Image or Map toolbar as applicable.

b Click the label of the control point to edit.

c Click on the image or map to move the control point.

d Repeat as needed, then edit the corresponding points if necessary on the image or
map.

e Click the Apply  button to check the result.

Transform a Registered Image for Use
as a Layer

 You can use the image transformation function to prepare a raster image to be opened
as a map layer in MapCalc. Image transformation creates a full set of data points for a
map, based on the registration points. A.tab file is generated, which you can access using
either the Map Set>Add New Layers command or the File>New command.

To transform a registered image into a MapInfo Table:

1 Select File>Transform Image.

2 Click Open Image File, then choose the image file that you previously registered with
the Register Image function.

3 Click Save As, then enter a name for the.tab file. When you click Save, the MapInfo
table is created.

"""" Note: The More button expands the dialog box to show the affine transformation
parameters. These are available for users with special requirements to enter their
own parameters, but in most cases the entries should not be changed.
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8.8.8.8. Menus & Toolbars

Toolbars

Toolbar buttons have corresponding menu commands. See Menus for function
descriptions.

Main ToolbarMain ToolbarMain ToolbarMain Toolbar

Map ToolbarMap ToolbarMap ToolbarMap Toolbar

Copy View to
Al l  Maps

Shading
Manager

Save Picture

Contour

Contour
Lines

Show
Grid

Use
Cel ls

Data Type

Cei l ing
Contour L ines

Cei l ing
Contour

Floor
Contour L ines

Floor
Contour

New Map Set

Open Map Set

Close Map Set

Save Map Set
Export
Map Set

Print
Reports

Layer
Manager

Onl ine
Help

Tile
Windows
Vertical ly

Map
Analysis

Tools

Tile
Windows
Horizontal ly

Cascade
Windows
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Tools ToolbarTools ToolbarTools ToolbarTools Toolbar

Menus

File MenuFile MenuFile MenuFile Menu

New Create a new map set using the Map Set Creation Wizard.

Open Open an existing.rgs file.

Close Close the current file.

Save Save the current map set as a.rgs file.

Save As… Save the current map set as a.rgs file with a different file name.

Export Map Set Saves the active file as a MapInfo table (.tab) file, ESRI
shapefile (.shp), dBASE (.dbf) file, comma delimited text (.csv)
file, MapInfo Interchange (.mif) file, or AgLeader 3000 (.tgt) file.

Send to MapInfo
(MapCalc Professional)

Launch MapInfo Professional and open all of the layers in the
current map set. The map set is opened as “temporary” files in
the MapCalc\Send To folder. Each time you use the Send To
MapInfo command, the files in this folder are overwritten. To
save the layers in .tab format, use Save As in MapInfo and
select a different folder in which to save the files.

Print Opens the Report Printing dialog box.

Image Registration Opens the Image Registration utility, which enables you to geo-
register raster images in TIFF, JPEG, or BMP format.

Image Transformation Opens a Image Transformation utility for converting geo-
registered TIFF files to MapInfo tables.

Last Open Files A list of recently opened.rgs files. This shortcut allows you to
open the last file you used by clicking on it here, rather than
going through the Open dialog.

Exit Closes the program.

Select

Zoom Out

Zoom In

Rotate
Pan

Reset to
Defaul ts
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Map Set MenuMap Set MenuMap Set MenuMap Set Menu

This menu is available when a map set is open.

Manage Layers Opens the Manage Layers dialog box for selecting maps to view,
renaming, and deleting map layers from the map set.

Map Analysis Opens the Map Analysis dialog box, which enables you to perform
advanced mathematical functions using data columns as variables.

Create Graph Scatter Plot for determining the correlation between two
parameters.

Histogram for determining data value distribution.

Add New Layers Starts the Add Layers Wizard, if you have already created a grid
set and need to add more layers.

Graph MenuGraph MenuGraph MenuGraph Menu

This menu is available when a graph (scatter plot or histogram) is open. You can access
menu options marked below with an asterisk (*) by right-clicking on a map to activate a
Shortcut menu.

Properties* Access to choices for marker style, size, and color for the selected
graph. Default graph options are in the Default Options dialog box.

Reset View* Resets the properties for the selected graph to program defaults.

Regression Line Toggles the visibility of the regression line in scatter plots.

Save Picture As…* Saves the selected graph as a graphic image file.

Close Graph* Closes the selected graph window.

Tools MenuTools MenuTools MenuTools Menu

This menu is available when a map set is open. After making changes with tools, you
can use the Reset View command from the Graph or Map menus to return to the
default settings if desired.

Select The Select pointer is the default tool. Use it to:

• Double-click in the margin area of a map or graph window to
open the Properties dialog box.

• Double-click on a map to open the Data Inspection window.

• Double-click on a legend to open the Shading Manager.

• Float the Select tool over the grid to see the grid cell values pop
up on screen.

Zoom In To zoom in, drag a box around the area of the map to be magnified.



Menus & Toolbars

38

Zoom Out This tool enables you to zoom the map scale either in or out. To
zoom, click and hold the primary mouse button on the map as you
slide the mouse forward or back. You will see the view changing as
the mouse moves. When you release the mouse button, the map is
redrawn to the new scale.

Rotate This tool changes the view angle of the map when viewing in 3D
mode. With the rotate tool selected, click and hold within the plot
area as you move the mouse. When finished, release the mouse
button and the map is redrawn.

Move The Move tool lets you click on the map and drag it within the
window. It is helpful if you are viewing at a high zoom level and
you want to see a part of the grid that is outside the edge of the
viewing area.

Map MenuMap MenuMap MenuMap Menu

This menu is available when a map set is open. Menu options marked below with an
asterisk (*) can be accessed by right-clicking on a map to activate a Shortcut menu.

Properties* Opens the Map Properties dialog box.

Layer Expands to give the following options:

• Contour toggles display of ranges thematically over the 3D
layer, using the settings in the Shading Manager.

• Contour Lines toggles lines between ranges on the contour
map.

• X,Y Mesh toggles the X,Y grid of cells (on 3D layer only).

• Use Cells makes each cell one color, rather than
interpolating across cells.

• Data Type toggles whether the data is displayed as discrete
data (one value assigned to each grid element) or
continuous data (values interpolated across the grid).

Floor & Ceiling Each expand to offer the following:

Contoured toggles a 2D contour map of the 3D layer on the floor or
ceiling.

Contour Lines toggles contour lines on the floor or ceiling.

Legend Toggles display of legend, showing ranges by color and
minima/maxima. Select None, or select the location for the legend
in relation to the map.

Overlay Allows selection of open data sets for thematic overlay on the
current grid. When using an overlay, the 3D layer displays the
values for the original data set. The overlay is a themed contour
map over the grid. Not available for 2D maps.
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3D Toggles between 3D and 2D view.

Shading Manager* Dialog box for specifying range calculations, colors, and templates.

Reset View* Returns map to default view after changing viewing angle.

Copy View* Copies the orientation and dimension of the current map to all
other maps. Does not copy theme.

Print Opens the Report Printing dialog box.

Save Picture As…* Saves the contents of the current map window (grid, legend, and
map title) as a JPEG (.jpg), PNG (.png), metafile (.wmf,.emf) or
bitmap (.bmp) image.

Close Map* Closes the currently selected map. This does not close the program.
Reopen map windows using the Manage Layers command from the
Map Set Menu.

View MenuView MenuView MenuView Menu

Options Open the Default Options dialog box, which contains settings for
global program properties including startup behavior, standard
units, and the appearance of maps, graphs, and reports.

Toolbars Check which toolbars should appear on the MapCalc window. All
toolbars are visible by default.

Data Inspection Opens the Data Inspection window, allowing you to view the data
contained in the entire map set as you hover the mouse over any
map.

Status Bar The status bar is located along the bottom margin of the MapCalc
window. As you hover the mouse over a map, the status bar
displays the lat/lon coordinates, X,Y grid coordinates, and the value
in the current cell.

Window MenuWindow MenuWindow MenuWindow Menu

Close Close the selected window. To reopen a window, use the Manage
Layers dialog box to view the layer. The map reopens with program
defaults applied.

Close All Close all open windows. This does not close the map set.

Arrangement
Options

Tile the open windows vertically or horizontally, or cascade (stack
offset) the open windows. Minimize all windows to clear the
MapCalc screen while keeping the windows open in the current
map set.

Selection List List of open windows. Select a window to bring it to the front.
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Help MenuHelp MenuHelp MenuHelp Menu

About Displays MapCalc version, copyright, and contact information.

Contents and Index Opens MapCalc Online Help.

Register Software MapCalc must be registered, or it will not operate after the trial
period. Select this menu command to start the Registration Wizard.
This Wizard will lead you through the registration process. You can
register by phone or online. Have your serial number ready when
you begin.
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9.9.9.9. Map Analysis Tools

Select Map Set>Map Analysis or click the  toolbar button to open the Map
Analysis dialog box.

This dialog box contains many complex functions for statistical and spatial analysis,
manual equation entry, and creating macros (scripts) for repeated use or custom
tutorials.

The analysis commands are sorted in drop-down lists. When you select a function from a
list, a dialog box will open to assist you in entering the necessary parameters for the
analysis. To learn about the analysis functions, select from the lists below, or click the
Help button in each analysis function dialog box.

Using the Map Analysis Dialog Box

• As you complete the dialog box entries for the map analysis functions, script
commands are entered in the script window (the script-building area located below
the drop-down function lists).

• You can edit a command by double-clicking in the Detail column.

• You can move the command lines up or down by dragging the function name on the
left side of the script window.

• You can run a single command line by right-clicking on the command line, then
selecting Execute from the Shortcut menu.

• You can run a full script by right-clicking on any command line, then selecting Run
Script from the Shortcut menu.

• To remove an interim map generated by the script, select the Clean Up check box for
the command line.

• To set up options for when script commands run, and whether maps open in new
windows or a single workspace window, make selections in the Default Options
dialog box, Analysis tab.
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Tools By Category

The analysis tools are sorted in lists within the Map Analysis dialog box, as shown below.
The Macro list is available when selected in the Options dialog box.

Reclassify Overlay Distance Neighbors Statistics Import Macro

Clump Calculate Drain Interpolate Analyze Import Note

Configure Composite Radiate Orient Cluster Export Help

Renumber Compute Span Profile Compare Describe Pause

Size Cover Spread Scan Correlate Remove

Slice Crosstab Stream Slope Regress

Intersect Relate
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Menus

Script MenuScript MenuScript MenuScript Menu

New Start a new script (.scr file). A script is a macro executed through the Map
Analysis dialog box.

Open Open a saved script.

Close Close the current script.

Save Save the current script.

Save As Save the current script with a new name.

Execute Run the current script.

Exit Close the Map Analysis dialog box.

Edit MenuEdit MenuEdit MenuEdit Menu

Edit Make changes to the selected script command.

Cut Remove the selected script command.

Copy Copy the selected script command.

Paste Paste the selected script command at the insertion point (cursor).

Shortcut MenuShortcut MenuShortcut MenuShortcut Menu

Edit Make changes to the selected script command.

Delete Remove the current command from the script.

Execute Run a single selected command.

Run Script Run the entire script (macro).
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Reclassification Tools

Reclassification tools include Clump, Configure, Renumber, Size, and Slice.

ClumpClumpClumpClump

Clump uniquely identifies groups of cells with the same value, but geographically separated.
It is most often used to identify contiguous parcels of the same condition on a map. Consider
a map with lake cells assigned the value four. As all of the lakes have the same value,
MapCalc cannot distinguish between the individual lakes until they are clumped and
assigned unique numbers.

Clump creates a new map by uniquely identifying individual "clumps" of cells that appear on
an existing map. A clump is defined as a group of one or more nonzero-valued cells with the
same assigned value that are adjacent or in the same vicinity. Cells that are more than the
specified cell distance apart (AT <# spaces>) are placed in separate clumps.

You specify the "reach" with the AT keyword. A reach over 1 allows cells that are not
immediately adjacent to be considered as members of the same clump. In habitat
applications, animals can move from one patch to another over short distances (reach), with
the entire collection of patches forming a single habitat unit.

Example: CLUMP Forests FOR Individual-Parcels

Clump <existingMap>

At <# gridSpaces>default = 1 = one cell

Select Mode

Diagonally Uses a box-shaped reach.

Orthogonally Uses a cross-shaped reach.

For <newMap>
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ConfigureConfigureConfigureConfigure

Configure assigns new values characterizing the shape and integrity of the area associated
with each map category. Two types of shape assessments are used: boundary configuration
and spatial integrity. Boundary configuration uses relationships between the perimeter and
area of features. Features with more perimeter per unit area are said to be more irregular.
The keywords EDGES, SIDES, and CONVEXITY deal with boundary configuration.

Configure summarizes the shape for entire map categories wherever they occur on the map.
If you desire shape summaries for individual parcels of each map category, you must use the
Clump function on the map before you configure it.

Example: CONFIGURE Covertype FOR Perimeter

Configure <existingMap>
Summarizes the shape for entire map categories. Use
CLUMP then CONFIGURE for individual parcels.

Select Mode

Edges Number of exterior cells.

Sides Number of exterior cell sides.

Convexity Index of boundary regularity.

Fragments Number of separated groups.

Holes Number of interior violations.

Euler Index of spatial integrity.

Select Mode

Map Only Creates a new map.

Report Only Generates a tabular summary that can be directed TO a file.

Both Creates a map and generates a text file.

To <filename> Writes the report to a text file.

For <newMap>
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RenumberRenumberRenumberRenumber

Renumber assigns new values to the category values of an existing map. It is one of the
most frequently used operations in MapCalc as it prepares maps for subsequent processing.
Renumbering can be made to individual values, or to a range of existing values.
The function is used to create new maps out of old maps with the same spatial distribution of
categories but with different values. For example, aesthetic value may be based solely upon
vegetation type. A vegetation map could be renumbered, such that the categories expressed
aesthetic values rather than vegetation type. The Renumbered map does not carry over the
labels from the old map. This Renumbered map can now be relabeled, stored, and accessed
independently of the vegetation map.

Note: Values assigned can be interval or real numbers. Last assignment for a value or range
of values is used (e.g., Assign 0 to 1 thru 100 assign 1 to 50 results in 0 assigned to all values
except 50, which is assigned 1).

Example: RENUMBER ROADS ASSIGNING 5 TO 1 ASSIGNING 3 TO 2 ASSIGNING 1
TO 3 THRU 4 ASSIGNING 10 TO 21 THRU 43 FOR Road-Friction

Renumber <existingMap>

New Value Enter the value to assign to Old Value.

Old Value Enter the value to be reassigned with New Value. If assigning a value
to a range, enter the minimum of the range.

Old Upper Value If assigning New Value to a range, enter maximum of the range here.

Add Click after entering values to add the ASSIGNING phrase to the
command line. Repeat as needed.

Del Highlight an ASSIGNING phrase, then click to remove it from the
command line.

For <newMap>
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SizeSizeSizeSize

Size assigns new values according to the size of the area associated with each map category.
It calculates the area for entire categories (map values) which are often composed of
numerous separate groupings. Use Clump, then Size to determine the area of individual
groups of the same category. For example, a map of different forest types can be Clumped to
uniquely identify each forest stand, then Sized to produce a map showing the acreage of each
stand. The size is reported in number of cells in each map category.

Example: SIZE Covertype FOR Cover-Size

Size <existingMap>

For <newMap>
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SliceSliceSliceSlice

Slice divides the range of values on a map into a specified number of evenly spaced intervals
(contours). It is most often used to "generalize" a complex map, such as elevation, into a
smaller set of values, which can be visualized. Zero is assigned to any location with an
existing value outside the range specified.

Example: SLICE Elevation INTO 10 FROM 500 THRU 2500 FOR 200-Foot

Slice <existingMap>

Into # of intervals

From Low boundary of the range to be Sliced. Default is lowest existing
map value. Both positive and negative values are accepted, however
FROM must be smaller or more negative than THRU.

Thru High boundary of the range to be sliced. Default is highest existing
map value. Both positive and negative values are accepted, however
THRU must be larger or more positive than FROM.

Select Fill

Zero Fill Default setting. Values outside the range are set to zero.

Completely Values less than the low boundary are set to 0. Values greater than
the high boundary are set to the high boundary + 1.

For <newMap>
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Overlay Tools

Overlay tools include Calculate, Composite, Compute, Cover, Crosstab, and Intersect.

CalculateCalculateCalculateCalculate

Calculate is a manual equation editor that expands upon the more automated Compute
function. Calculate helps you build equations by letting you choose the individual
elements from the menus. Alternatively, you can type the entire equation into the blank.

There is no limit to the length of an equation. Use parentheses and brackets as needed to
specify order of operations.

After a map has been created from an equation, you can inspect the equation in the Map
Properties dialog box.

Menu options include:

Maps - lists the available mapped data sets to use as variables. Selecting a map enters it
in the editor window.

Functions - select any function from the following submenus to enter it in the window:

• Operators - basic mathematical operations, i.e., sum, difference

• Common - mathematical functions, i.e., exponent, square root

• Logical - relational operators, i.e., and, or

• Grid - statistical functions, i.e., maximum, minimum

• Trig - trigonometric functions, i.e., sine, tangent

After you build the equation, click Ok to generate the resulting map.



Map Analysis Tools

50

CompositeCompositeCompositeComposite

Composite creates a map summarizing values from a data map which coincide with the
categories of a template map. In other words, it is used to calculate composite attributes by
combining two maps. Each category on the template map is compared to the aggregated
values in corresponding positions on the data map. To summarize individual clusters of a
region, first Clump the template map.

For instance, Composite could be used for finding the average slope for cover type categories.
MapCalc keeps a record of each category value in the template map, and the appropriate
aggregate value in corresponding cells on the data map. For each category of the Covertype
map, MapCalc determines the number of corresponding cells. MapCalc then calculates the
sum of corresponding cells for each category in the Slope map. It divides the sum by the
number of cells, giving the average slope for each category. The interpretation for any point
on the resultant map is, "This location belongs to a cover type whose average slope is [x]%."

Example: COMPOSITE Districts WITH Covertype AVERAGE FOR Avg-Cover

Composite <templateMap>

With <dataMap>

Select Command

Average The average of the data map values corresponding to each template
map category will be included on the new map.

Median The midpoint of the data map values corresponding to each template
map category will be included on the new map.

Stdev The standard deviation of the data map values corresponding to each
template map category will be included on the new map.

Majority The new map is given the value found most often in the data map for
each category of the template map.

Coffvar The coefficient of variation of the data map values corresponding to
each template map category is included on the new map.

Minority The new map is given the value found least often in the data map for
each category of the template map.

Total The total of the data map values corresponding to each template map
category is included on the new map.

Diversity The new map is given the number of different cell values found in the
data map for each category of the template map.

Maximum The maximum of the data map values corresponding to each
template map category is included on the new map.

Minimum The minimum of the data map values corresponding to each template
map category is included on the new map.
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Deviation Gives each cell on the new map the difference between the average of
the data map values and the value in the template map for that
region.

Proportion Determines the percent of data values that are the same as the
template value.

Ignore <nullValue>

For <newMap>
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ComputeComputeComputeCompute

Compute creates a map as the mathematical or statistical function of two or more maps or
constants. It is used for many calculations based on a cell-by-cell overlay procedure. Compute
creates a new map by calculating values as a function of several maps or constants.

The Compute operations provide basic arithmetic and trigonometric operators. The
Maximum and Minimum operations will combine maps to determine the maximum or
minimum value at each location. For most Compute operations, a constant value may be
specified instead of a map name.

Any number of Compute operators may be contained in one command string. Maps are
processed in the order specified.

Example: COMPUTE Covertype Times 10 Plus Soils FOR Cover-Soils

Compute <existingMap>

Operation Select an operator from the list.

Another Map Choose from the list if you want to use an open layer as an operand.

Constant Enter a constant if necessary.

Another Map

Constant

Add Add the phrase to the command line.

Del Remove the highlighted phrase from the command line.

For <newMap>
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CoverCoverCoverCover

Cover creates a new map where values of the top map replace the values on the bottom map,
or stack of maps. In other words, it is used to combine maps such that the categories of the
top map overlay take precedence over the values on any map beneath it. This procedure is
similar to overlaying several maps on a light-table, except numbers are substituted for
opaque map colors.

Note: A map value entered in the Ignore blank is analogous to a transparent location on a
map.

This technique can be used to "mask" one map with another. For instance, a mask can be
constructed by Renumbering an area of interest to zero with all other locations assigned a
unique border value. This mask can cover another map to isolate its values for just the area
of interest.

Example: COVER Covertype WITH ROADS FOR Roads-Over-Cover

Cover <bottomMap>

With <topMap>

With <anotherMap>
Enter another map to “stack” if necessary.

Ignore Optional value in <topMap> that will not cover values in other
maps.

For <newMap>
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CrosstabCrosstabCrosstabCrosstab

Crosstab generates a spatial coincidence table of the relative occurrences of the categories of
two maps, and the result is output to a text file.

The output table contains the first map name and categories, second map name and
categories, number of cells that occur in each pair of categories, and the joint occurrence
of both categories throughout the entire map area. Select “Completely” mode to include
statistics on weighted joint occurrence of map categories. This information provides
insight into the strength of spatial coincidence.

Example: CROSSTAB Covertype WITH Soils COMPLETELY

Crosstab <firstMap>

With <secondMap>

Select Mode

Simply Generates a table of simple category frequency and coincidence. The
first six columns of the table contain the frequency of occurrence (#
of cells) for the categories on both maps considered separately. The
next column identifies the joint frequency of combinations of
categories, expressed in cell counts (# of cross). The final column
expresses the total joint occurrence as a percent of the entire map
area.

Completely Includes coincidence statistics plus correlation and weighted
frequency statistics. This table contains the same information as the
simple table in the first six columns.

The relative strength of the joint occurrence is contained in the next
four columns. The %Map Area statistic is computed by dividing the #
of Cells by the # of Cross and expressing it as a percent. This
statistic normalizes the frequency of joint occurrence to the total
occurrence of each map category. If the %Map Area is low it
indicates a fairly insignificant joint occurrence. If it is high, it
indicates a coincidence between categories that is significant. It
indicates that the joint occurrence dominants the total occurrence of
a category-- e.g., Category A on the primary map is very often found
with Category Z on the secondary map if the %Map1 Area is above
75%.

The final column and two rows separating the primary map
categories on in the table summarize the "score." The Wtd Score
weights the joint occurrence (# of Cross) by multiplying it by the
secondary map category value.

To <fileName>
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IntersectIntersectIntersectIntersect

Intersect creates a map that assigns new values to pairwise combinations of values on two
maps. The operation compares values at the corresponding cell location of two existing maps.
If a specified pair of values is found, it assigns a new value to the location.

In a sense, Intersect is a two-map Renumber operation. Instead of assigning a new value to
an old value on a single map, Intersect assigns a new value to a pair of values on two maps.
This function is frequently used in geo-searches.

The Crosstab function provides a tabular summary of Intersect results. The tabular
summary provides additional information on the intersection.

Example: INTERSECT Covertype WITH Water ASSIGNING 1 TO 3 AND 2 FOR Forested-
Streams

Intersect <existingMap1>

With <existingMap2>

Assigning <newValue>

To <map1Value>

And <map2Value>

Add Add the phrase to the command line.

Del Remove the highlighted phrase from the command line.

Completely Automatically assigns sequential values to all value pairs.

Select

Zero Fill Assigns a 0 to unassigned pairs.

Old Fill Retains existing values at locations with unassigned value pairs.

For <newMap>
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Distance Analysis Tools

Distance analysis tools include Drain, Radiate, Span, Spread, and Stream.

DrainDrainDrainDrain

Drain creates a map indicating the number of steepest paths (optimal path density) from a
set of locations along a surface. It calculates all downhill paths extending from a starting
location specified on one map (sourceMap) over a three-dimensional surface (surface map).
The surface map may be a topographic surface map, a cost surface map, or any other map in
which the cell values are represented as height.

This function differs from the Stream function, in that paths are calculated from all target
cells rather than just a single cell.

Note: Zeros (0) and Null values on the sourceMap indicate areas not to be drained.

Example: DRAIN Housing DOWNHILL ACROSS OVER Elevation FOR Runoff

Drain <sourceMap>

Over <surfaceMap>

Select Weight

Simply Counts the number of paths through each cell. The resultant map is
termed an "optimal path density surface."

Weighted Sums the sourceMap values of all paths passing through a cell. The
resultant map is termed a "weighted optimal path density surface."
Be aware that the weighted sums can rapidly reach the maximum
cell value of 32,767, particularly if the Absolutely option for path
movement is specified.
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Select Mode

Steepest Takes the steepest path along the surface. This procedure is similar
to water moving along a terrain surface. At each position along the
path, the surfaceMap values of the eight surrounding locations are
considered. Surface values that are greater than (uphill), or equal to
(flat) the path position are not considered. The slope to each lower
position is computed and the steepest is chosen as the next movement
along the path. If two positions are equally optimal, the path moves
to both.

Absolutely Steps via lowest neighbor without calculating slope. At each position
along the path, the surfaceMap values of the surrounding eight
locations are considered. The path moves to all location(s) containing
the lowest surface value.

Thinned Steps to the center cell if three or more equally optimal steps are
found.

For <newMap>
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RadiateRadiateRadiateRadiate

Radiate creates a viewshed map indicating areas that are visible from locations on the
viewersMap. It can be used to identify all the cells that can be seen from a single location, or
groups of locations. All cells on the viewshed are on an unobstructed line of sight between
them and cells on the viewersMap. If any portion of a cell can be seen, then the entire cell is
marked as seen. The visual connection can be modified by cell position on a topological
surface (elevation), viewer height on the surface (for instance, view from a fire tower), effects
of visual screens such as trees, and height of special objects such as smokestacks.

Example: RADIATE Housing OVER Elevation AT 15 Completely FOR Visual-Exposure

Note: All maps must have same distance units (i.e., feet or meters).

Radiate <viewersMap>

Over <surfaceMap>
Surface over which the viewshed is to be constructed. This map can
be an elevation map describing topography, a cost surface reflecting
cut and fill heights and the cost to bring to grade, or any other value
that may con strain the "view."

To <# gridSpaces>default = 5
Maximum horizontal radius (# of cells) of a line of sight around each
viewer location.

At <viewer_heightValue> default = 0
Height of the viewpoint above the surfaceMap. The default simulates
the view from the surface (bug's eye view).

Through <screen_heightMap>
Map containing cells that block any line of sight. For example, a
forest map with values of 75 feet per forested cell would constitute a
screen map that automatically overlays the surface map when
Through is specified.

Onto <target_heightMap>
Map containing cell values reflecting the height of features above
corresponding cells of the surface map. For example, visible height
values might represent heights of smokestacks above the
topographic surface map. A possible analysis could be to deter mine
at what viewing height any smokestack is visible above an
intermediate range of hills.

Select Mode

Simply Identifies all visible cells within the viewshed. Locations with one or
more visual connection are assigned the value 1.

Completely Identifies the number of connected viewer cells. Larger values
indicate higher visual exposure to the set of viewer locations. For
example, a visual exposure map from a road network characterizes
each location as to how many road cells are visually connected to it.
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Weighted Calculates the sum of the values of connected viewer cells. Larger
values indicate higher visual exposure to the set of weighted viewer
locations. For example, each road type might be assigned a value
indicating the relative volume of traffic. The visual exposure from
such a map characterizes each location as to the total sum of the
weights visually connected to it. A location connected to just a few
heavy duty roads cells would receive a larger exposure index that a
location which is connected to many more light duty roads.

Degrees Identifies the maximum prominence angle of connected viewer cells.
Larger values indicate areas dominating a viewshed. The maximum
degree of exposure is assigned to areas seen more than once. For
example, a prominence map from a road network characterizes the
maximum impact of any area as a person drives through the
network. The maximum degree of exposure is assigned to areas seen
more than once.

For <newMap>
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SpanSpanSpanSpan

Span creates a map indicating narrowness within all non-zero areas on a map. A narrowness
value is assigned to each cell that is equal to the length (in grid spaces) of the shortest line
connecting opposing edges of the feature. For example, the narrowness of square feature is
small in the corners and becomes progressively larger toward the center. An hourglass-
shaped feature is wider at its ends (large narrowness values) and smaller in the middle
(small narrowness values). Values are only computed for non-zero categories.

The Spread function can be used to calculate relative edge proximity, a related statistic. The
technique determines the distance to the nearest edge. The narrowness statistic calculated
by SPAN, on the other hand, calculates the shortest combined distance to opposing edge
cells. Many animals respond to feature narrowness, which makes Span useful in assessing
habitat.

The Configure function also contains several related feature shape statistics.

Example: SPAN Covertype WITHIN 3 FOR Narrowness

Note: Span is a memory-intensive operation, so WITHIN should be as small as the
application will allow.

Span <existingMap>

Within <# gridSpaces>default = 3-cell radius
Number of grid spaces around a cell to search for edges. If all
opposing edges are more distant than 2 times WITHIN, this value
is assigned to indicate that the edges are at least that far apart.

For <newMap>
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SpreadSpreadSpreadSpread

Spread creates a map indicating the shortest effective distance from all cells with non-zero
or non-null values to other cells within the range specified in the “To” blank. Spread replaces
zero values with the distance to the nearest non-zero cell (within the specified distance
range). In order to return useful information, the map selected in the “Spread” blank should
contain isolated points to be used as starting points, surrounded by zero-value cells which
will be replaced by the calculated result.

The measurement can be affected by the nature of the movement, and by the conditions in
which the movement takes place. For example, a lake acts as an absolute barrier to a non-
swimmer, so it has to be circumvented. A steep, densely-forested area represents a relative
barrier that slows down a hiker.

In addition to absolute and relative barriers, Spread can be constrained to flow like water,
uphill or downhill over a surface. These guides are not constrained to terrain conditions, but
can represent up and down wind by similar movement over a barometric surface.

Example: SPREAD Roads TO 100 OVER Elevation FOR Prox-Road

Note: UPHILL, DOWNHILL, ONLY and ACROSS work only with OVER.

Spread <existingMap>
Distances are measured from all locations with non-zero and non-null
values.

Null Value Enter a value to be ignored.

To <# gridSpaces>default = 5-cell distance

Through <frictionMap> <1 = absolute barrier
Values on selected map represent resistance to movement, or friction.
The distance (diagonal or orthogonal) is multiplied by the friction value
to determine effective distance of each cell. The values on the output
map indicate multiples of increased friction. For example, a friction
value of 5 is five times more difficult to cross than a friction value of 1.
Fractional friction can be expressed as a two-digit number. For
example, a friction value of 15 is 1.5 times more difficult to cross than a
value of 10. Friction values of zero or less are considered absolute
barriers (infinitely high friction).

Over <surfaceMap>
The values on this map are assumed to form a 3-dimensional surface.
Movement up, down and across this surface can be specified. For
example, moving uphill over a detailed elevation surface can identify
the watershed of a point.

Select

Uphill Specifies that movement is in an uphill direction over surfaceMap.
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Downhill Specifies that movement is in a downhill direction over surfaceMap.

Select

Only Use with Uphill or Downhill to specify that Spread will stop if it
encounters a flat area.

Across Allows movement over flat areas.

Select

Simply Measures distance from a feature in cell units starting from 1.

Explicitly Measures distance from a feature in cell units starting from the
feature’s cell value.

Weighted Measures distance from a feature in cell units times the starter cell
value. This distance is termed a "gravity measure" and is analogous to
rates of movement of cars travelling different speeds.

For <newMap>
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StreamStreamStreamStream

Stream creates a map identifying the steepest , or optimal, path along a surface. If the
surface map depicts terrain elevation, the optimal path is the one with the least friction in
which water would follow. If the surface is an accumulated distance map, such as a travel-
time map, the path is the shortest, but not necessarily straight line connecting the target cell
to the bottom of the surface. This route represents the quickest path between the two
locations. If the surface is an accumulated cost surface, the path is the least-cost route.

The Drain function is similar to Stream, except paths from all cells are summed to create an
optimal path density surface.

Example: STREAM Locations OVER Elevation Simply Steepest Downhill FOR Steepest-
Path

Stream <existingMap>

Starter Cell Enter row and column to originate the path from one cell.

Over <surfaceMap>

Select

Simply All cells along the path are assigned the value 1.

Incrementally The value of each cell along the path equals the number of cells
from the starting location.

Select

Steepest Takes the steepest path.

Absolutely Steps via lowest neighbor.

Thinned Steps to the center cell if more than three equally optimal steps
are found.

Select

Downhill The path proceeds in a downhill direction.

Uphill The path proceeds in an uphill direction.

Select

Only The path does not proceed across “flat” areas on the surface map
(areas of equal value).

Across The path proceeds across "flat" areas on the surface map.

Completely Identifies the number of paths passing through each cell.

For <newMap>
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Neighbors Analysis Tools

Neighbors analysis tools include Interpolate, Orient, Profile, Scan, and Slope.

InterpolateInterpolateInterpolateInterpolate

Interpolate creates a continuous surface from point data by performing a nearest neighbor
analysis to fill in missing values on a map. Interpolated values may be determined by
weighted nearest-neighbor or discrete interpolation.

Example: INTERPOLATE Locations AROUND Roads Discretely FOR Interpolated-
Locations

Interpolate <dataMap>

Around <maskingMap>
Specifies a map with zeroes indicating areas not to be
interpolated.

Within <# grid spaces> default = 5
Specifies search radius for values included in the interpolation.

Using <# data points> default = 6
Used with the Continuously option. Specifies number of neighbors
included in the interpolation. MapCalc uses only the number of
neighbors specified, even if the WITHIN command includes more
potential neighbor cells.

Select

Continuously Indicates a weighted nearest-neighbor interpolation is to be
performed.

Discretely Indicates a simple nearest-neighbor interpolation is to be
performed.

Select

Maximum Used only with the Discretely option. If two or more neighbor cells
are equidistant, the greatest value of the equidistant cells will be
used.

Minimum Used only with the Discretely option. The minimum value among
equidistant neighbors is assigned to each interpolated cell.
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Select

Substituting New values are interpreted for all map locations including sample
data locations. This allows residual analysis of interpolation
performance.

Retaining Retains all point data values.

Ignoring <nullvalue>
Value used to indicate non-sampled locations. This value must be
a number that is not included in the range of sample values. For
example, 0 feet elevation is a valid height above sea level,
therefore, the null value should be assigned a number such as -99.

For <newMap>



Neighbors Analysis Tools

67

OrientOrientOrientOrient

Orient produces a map of aspects or azimuths along a surface map. It calculates azimuth
degrees or aspect octants (eight compass directions) of each cell on a map representing a
continuous three-dimensional surface.

Vertical scale units must be consistent with the horizontal scale of the map. If the map scale
is in kilometers, for example, and the vertical scale units (map cell values) are meters, all cell
values must be divided by 1000 before the map is Oriented. It is good practice to select
equivalent map cell units whenever Orient, Slope, or Radiate operations are anticipated.

Example: ORIENT Elevation PRECISELY FOR Aspect-Map

Orient <existingMap>
The values on this map are treated as forming a 3-dimensional surface.
The MapCalc scale units (X,Y) must correspond to the map values (Z).
For a topographic surface, the units for X,Y and Z should be consistent
(either feet or meters). For abstract surfaces, such as a cost surface, the
range of map values should be at the same order of magnitude as the
MapCalc scale.

Select Mode

Octants Cells will be assigned the values N, NE, E, SE, S, SW, W, NW, or no
aspect (flat)

Precisely Cells will be assigned azimuth values of 1-360, or 361 meaning no
aspect (flat)

For <newMap>
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ProfileProfileProfileProfile

Profile characterizes the cross-sectional profile along a continuous surface. The profile
process is similar to slicing a loaf of bread, then holding up each slice. As you look at the side
of a slice, its top crust forms a line, termed the surface's profile. The up and down pattern of
the profile line is summarized by the Profile function. It creates a new map by assigning a
value to each cell based on the inclination of a line through it and two diametrically opposed
neighbor cells. As shown below, each cell (X) has eight neighbors:

1 2 3

4 x 5

6 7 8

Eight profiles can be drawn through the central cell. A profile can be drawn from neighbor 1
through neighbor 8; similar profiles can be drawn through neighbors 2 and 7, 3 and 6, and 4
and 5. Each of the four lines through three adjoining cells can be "viewed" from both sides of
the line. For example, the line through neighbors 1 and 8 can be viewed from the upper right
(northeast; eye in the upper right; profile runs SE-NW) and from the lower left (southwest;
eye in the lower left; profile runs NW-SE). Note that the viewing direction is perpendicular to
the direction the profile is running. In MapCalc reference, "north" is always toward the top of
the map.

The value assigned to each cell represents the inclination of the side slope through the cell.
Nine different inclinations are possible:

1 Relative Height: 1-2-3 Up-Up (constant upward rise)

2 Relative Height: 1-2-2 Up-Over

3 Relative Height: 1-2-1 Up-Down (inverted "V")

4 Relative Height: 1-1-2 Over-Up

5 Relative Height: 1-1-1 Over-Over (flat line)

6 Relative Height: 2-2-1 Over-Down

7 Relative Height: 2-1-2 Down-Up (upright "V")

8 Relative Height: 2-1-1 Down-Over

9 Relative Height: 3-2-1 Down-Down (constant downward)

For example, the inverted "V" shape of value 3 likely indicates a ridge on a topographic
profile. The upright "V" shape of value 7 likely indicates a gully. Each cell along a profile
"slice" is assigned a value (1 through 9) indicating the shape of the surface at that location.
The result is a continuous map of cross-sectional profiles along the direction specified by the
user.

Example: PROFILE Elevation FROM South AT 5 FOR S-Looking-N
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Profile <existingMap>
The MapCalc scale (X,Y horizontal cell distance) and the map values (Z
vertical distance) must be the same or compatible units.

From Mode Select the direction from which the profile is to be viewed. The view
direction is perpendicular to the direction the profile is running. The
default, North, means the view originates at the top of the map, directed
South.

At <percentRise> default = 5
Specifies that the slope from each neighboring cell to the next must be
greater than the percent rise value to identify a different profile class. For
example, AT 10 specifies that a rise of less than 10% between cells will be
considered flat.

Suppose the center cell in the 3x3 diagram above is 100 ft. elevation,
positions 4 is 120 ft., and position 5 is at 140 ft. When viewed from North,
the profile pattern is 140-100-120 (left to right). Using AT 10, this is profile
class 4, Relative Height: 1-1-2 Over-Up. However, using AT 0, the pattern
becomes profile class 7, Relative Height: 2-1-2 Down-Up.

AT 0 is very sensitive to profile class changes, whereas AT 25 or greater is
relatively insensitive. The default is best for most topography. AT 100
specifies a 100% slope, forming a 45 degree angle.

For <newMap>
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ScanScanScanScan

Scan is a smoothing operation that creates a map summarizing the values that occur within
the vicinity of each cell. A user-defined Scan window is moved over the data map, and each
map location is assigned a value summarizing the cell values within the window. The default
summary is the average value of cells in the window.

The size and shape of the "window" is controlled by specifying the number of cells (radius)
from the center cell and whether to use a circular or square shape. A portion of a map can be
scanned by masking with the AROUND option. The IGNORING option specifies a value to be
excluded from the operation.

Scan has been shown to be very useful in producing accurate point data interpolations when
combined with Interpolate: Discretely.

Example: SCAN Housing Total AROUND Roads FOR Road-Housing-Density

Scan <existingMap>

Select Orient Mode

Average Existing values are replaced with the average of the cell values
included in the Scan.

Stddev Existing values are replaced with the standard deviation of the cell
values included in the Scan.

Coffvar Existing values are replaced with the coefficient of variation of the
cell values included in the Scan.

Also termed relative standard deviation, this statistic normalizes
the standard deviation allowing comparison of variation between
different data sets.

Total Existing values are replaced with the sum of the cell values
included in the Scan.

Maximum Existing values are replaced with the largest of the cell values
included in the Scan.

Minimum Existing values are replaced with the smallest of the cell values
included in the Scan.

Median Existing values are replaced with the midrange value of the cell
values included in the Scan.

Majority Existing values are replaced with the most frequently occurring cell
value included in the Scan.

Minority Existing values are replaced with the least frequently occurring cell
value included in the Scan.

Diversity Existing values are replaced with number of different values
included in the Scan.
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Deviation Calculates the difference between the center value and the average
of the remaining values in the Scan. This statistic indicates how
different the center is from its surroundings. This statistic assesses
anomalies for interval and ratio data types.

Proportion Determines the percent of the window that is the same as the
center cell value. Existing values are replaced with the proportion
of the window that has the same value as the center cell. This
statistic assesses anomalies for nominal and ordinal data types.

Ignoring <nullValue> default = 0

Within default = 1

Number of grid spaces indicating the orthogonal radius of the
window.

Select Orient Shape

Circle Scan window will approximate a circle.

Square Scan window will be a square.

Around <maskingMap>
Specifies a map with zeroes indicating areas not to be scanned.
Areas with value = 0 are automatically assigned the IGNORING
value.

For <newMap>
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SlopeSlopeSlopeSlope

Slope creates a map indicating the slope (1st derivative) along a continuous surface. Slope
values for each cell are calculated using the eight neighbor cells, that is, a 3x3 window is
used for each calculation. The value is applied as a percent, to the centroid of the center cell.
The default procedure aligns a best-fitted plane to the values in the window, and assigns the
slope of the plane to the center cell. The window then shifts over one cell and the process
repeats. Other options use the maximum, minimum or average of the eight individual slopes
in the slope window.

Most often slope is determined for terrain elevation data. However, a first derivative or slope
map can be generated for any data that forms a continuous distribution in geographic space.
Slope indicates rate of change. For example, a slope map of a barometric surface indicates
how rapidly pressure is changing throughout the mapped area. Locations of steep slopes
(rapid change) indicate high winds. Similar interpretations exist for the slope maps of cost
surfaces (marginal cost) and travel-time surfaces (speed).

Note: The Orient function determines the direction of the rate of change throughout a map.

Example: SLOPE Elevation Fitted FOR Slope-Map

Slope <surfaceMap>
Values on this map are treated as forming a 3-dimensional surface.
The MapCalc scale units (X,Y) must correspond to the map values (Z).
For a topographic surface, the units for X,Y and Z should be consistent
(either feet or meters). For abstract surfaces, such as a cost surface,
the range of map values should be at the same order of magnitude as
the MapCalc scale.

Select Mode

Fitted Assigns slope of the best-fitted plane across the 3x3 window. (Default.
Best overall estimator of slope at a point.)

Maximum Assigns the maximum of the four possible slopes drawn through the
eight neighbors. (Tip: water responds to maximum slope.)

Minimum Assigns the minimum of the four possible slopes drawn through the
eight neighbors. (Tip: hikers tend to respond to minimum slope.)

Average Assigns the average of the four possible slopes drawn through the
eight neighbors. (A general slope index.)

For <newMap>
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Statistical Tools

Statistical Tools include Analyze, Cluster, Compare, Correlate, Regress, and Relate.

AnalyzeAnalyzeAnalyzeAnalyze

Analyze creates a map of the simple or weighted average, standard deviation, coefficient
of variation and several other descriptive statistics for two or more maps. It is most
frequently used to compute the arithmetic average of several maps.

Analyze creates a new map by computing the simple or weighted averages of two or more
existing maps on a cell-by- cell basis. The processing algorithm multiplies the values of
each specified map by its assigned weight, adds the weighted values for each cell, and
divides the total by the sum of the weights. Maps with larger weights influence the
average more.

Example: ANALYZE Soils TIMES 5 WITH Districts FOR Nonsense

Analyze <existingMap>

Times <weight> default = 1

With <anotherMap>

Times <weight> default = 1

Add Add the phrase to the command line. Repeat for WITH as often as
necessary.

Del Remove the highlighted phrase from the command line.

Ignoring <nullValue>
You can use the Renumber function to set areas to the 'ignored' value
before using Analyze

Around Identifies a map of locations to be processed. Null locations will not be
analyzed and simply retain the Null value.

Select Command

Mean Also called arithmetic mean, or average, of the map values associated
with each cell location on the set of specified maps. The mean is an
estimate of the central tendency (typical value) for normally
distributed data.

Variance Calculates the variance of the map values associated with each cell
location on the set of specified maps. The variance is an estimate of
the data dispersion about the mean for normally distributed data.

Variance is the square of the standard deviation.
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StdDev Calculates the standard deviation of the map values associated with
each cell location on the set of specified maps.

The standard deviation identifies the data intervals above and below
the mean that capture two thirds of the data.

Skew Skewness characterizes the degree of asymmetry of a distribution
around its mean. Positive skewness indicates a distribution with an
asymmetric tail extending toward more positive values. Negative
skewness indicates a distribution with an asymmetric tail extending
toward more negative values.

Kurtosis Kurtosis characterizes the relative peakedness or flatness of a
distribution compared with the normal distribution. Positive kurtosis
indicates a relatively peaked distribution. Negative kurtosis indicates
a relatively flat distribution.

Minimum Minimum value among the stack of map values for each grid location.

Maximum Maximum value among the stack of map values for each grid location.

Range Data range (maximum - minimum) among the stack of map values for
each grid location.

CoeffVar Coefficient of variation is a normalized measure of how widely values
are dispersed from the average value. It is computed by dividing the
standard deviation by the mean and multiplying by 100 to express as
a percent.

Median Middle value of a distribution (if sample size is odd) or average of two
middle values.

AvgDev The average deviation from the Mean among the stack of map values
for each grid location.

MedDev The average deviation from the Median among the stack of map
values for each grid location.

Majority Most frequently occurring number among the stack of map values for
each grid location. Often referred to as the Mode.

Minority The least frequently occuring number among the stack of map values
for each grid location.

Variety The number of different numbers occurring among the stack of map
values for each grid location.

AllStats This option generates fifteen maps—one for each of the summary
statistics noted above.

For <newMap>
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ClusterClusterClusterCluster

Cluster is used to identify areas with similar characteristics on a set of map layers. The
procedure in effect spears a set of values through a stack of map layers, then investigates the
data pattern formed by values to determine other locations that are most similar. For
example a location with values 100, 100, 100 for three map layers would be more similar to
another location with values 98, 96, 97 than to a location with values 15, 12, 17.

The first step in clustering establishes arbitrary "data centers" for each cluster by assigning
random data values. The similarity, or data distance, is computed for a map location to the
data center for each of the clusters. The location is assigned to the cluster with the closest
data center (i.e., the most similar data pattern). The procedure is repeated until all map
locations have an initial cluster assignment.

The next step calculates the average of the data values for the assigned locations within the
initial clusters. The averages form updated data centers that reflect the typical data pattern
of the current membership for each cluster. The updated values are used to redistribute
cluster membership by repeating the comparison of each location's data pattern to the
updated data patterns of the clusters.

Iterations of the above steps are made until cluster assignment does not change, or the
maximum number of 30 iterations is completed.

Similarity results are best when all map layers exhibit interval or ratio data types (e.g., 30%
silt, 60% silt, etc.) where the data range forms a bounded linear gradient.

Unpredictable results occur if the values within a data map are categorical (that is, the
numbers are identifiers with no numerical value), such as soil type #1, #2, etc. Numbers
exhibiting an ordinal relationship may be used, such as 1 = best soil, through n = worst soil.

Cluster <dataMap1>

With <dataMap2>
Repeat as necessary. Click Add after selecting each map.

Add Add the phrase to the command line.

Del Remove the highlighted phrase from the command line.

Using <#clusters> default = 5

For <newMap>
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CompareCompareCompareCompare

Compare creates a summary table of various comparison statistics between two maps.  The
comparison table summarizes the percent difference between the two specified maps on a
cell-by-cell basis.  The statistical indices test for significant differences between the two sets
of data.

Example: COMPARE Slope WITH Slope_max TO SSm_compare.txt

Compare <existingMap>

With <anotherMap>

To <newTextFile>

Example Output (Note: SCAN is used first for this example)

SCAN Elevation Average WITHIN 5 FOR Elevation_smoothed

COMPARE Elevation WITH Elevation_smoothed TO Compare_table.txt

% Difference # of Cells % of Map

-32.942 to -28.280 4 0.64

-28.279 to -23.617 7 1.12

-23.616 to -18.955 7 1.12

-18.954 to -14.292 27 4.32

-14.291 to -9.629 33 5.28

-9.628 to -4.966 48 7.68

-4.965 to -0.304 183 29.28

-0.303 to 4.359 252 40.32

4.360 to 9.022 45 7.20

9.023 to 13.686 19 3.04

NaN Values 0 0.00

-1.79%  <- Average % Difference

6.84% <- Standard Deviation

The Percent Difference table
is calculated by computing
the percent difference
between the maps on a cell-
by-cell basis.  The small
Average % Difference of -
1.79 indicates that the maps
are fairly similar.  Also, the
distribution of the % of Map
values are centered about
zero with nearly 70% (29.28
+ 40.32) between -4.965 and
4.359 percent difference.
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CI Variance: CI Mean:

Lower Limit = 42.00 Lower Limit = -2.33

Upper Limit = 52.44 Upper Limit = -1.25

The Confidence Interval reports the 95-
percent confidence range on either side of
the Percent Difference table mean and
variance.  In this example, there is a 95-
percent confidence that the actual mean
percent difference is between
-1.25 and -2.33; actual variance is between
42.00 and 52.44.

T Test

df = 624 degrees of freedom

t = -6.54 t statistic

p_value = 2.00 test probability

The T Test evaluates the distribution
function of a Student's t random variable
with the appropriate degrees of freedom.

Chi Squared Test

df = 624 degrees of freedom

chi_squared =
29192.46

chi-squared
statistic

p_value = 0.00 test probability

The Chi Squared Test evaluates the chi-
squared distribution for the statistic and
the appropriate degrees of freedom.

Wilcoxon W statistic 386028.00

2*E(W) – W 395847.00

p-value 0.22

Adjusted Wilcoxon statistic 387535.00

Adjusted 2*E(W) – W 394340.00

Adjusted p-value 0.30

W statistics for averaged ranks 386781.50

Standard error of W (averaged ranks) 6379.89

Standard normal score of W (averaged
ranks)

-0.65

Two-sided p-value of W (averaged
ranks)

0.51

Wilcoxon W statistic is a
rank sum test for identical
population distribution
functions.  If the difference
between the two
populations can be
attributed solely to a
difference in location, then
the Wilcoxon test becomes
a test of equality of the
population means (or
medians) and is the
nonparametric equivalent
of the two-sample t-test.
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CorrelateCorrelateCorrelateCorrelate

 Correlate derives a correlation matrix from a stack of maps. The correlation coefficient
indicates the interrelation between two maps.  A correlation of +1.00 indicates a perfect
direct relationship between the maps; a correlation of -1.00 indicates that one map’s values
change inversely in relation to the other’s.  Between the two extremes is a range of less than
perfect relationships, including zero that indicates the lack of any sort of linear relationship
at all (uncorrelated).

Correlate <independentMap>

With <independentMap2>
If using more than one independent map, select as needed from the
drop-down list. Click Add after each selection.

Add Click to add the independent map to the command line.

Del Click to delete a highlighted independent map from the command line.

To <newTextFile>

Example Output: CORRELATE Slope With Elevation TO SE_correlation.txt

Slope Elevation

Slope 1.000 0.432

Elevation 1.000

The correlation value of .432 indicates that slope is somewhat positively correlated with
elevation.  The 1.00 indices along the diagonal of the correlation matrix reports a perfect
relationship of a map to itself.
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RegressRegressRegressRegress

Regress performs linear regression analysis by using the "least squares" method to fit a line
through a set of data points in multiple maps. Each grid location identifies a series of values.
You can analyze how a single map (the dependent variable) is affected by the values of one or
more other maps (independent variables). For example, you can determine how crop yield is
affected by such factors as phosphorous, potassium and pH levels.

Regression is used for developing a prediction model based on a set of sampled data. The
relationship between the dependent and independent variables is determined by fitting a line
to the data that minimizes the deviations between the line and the data. The mathematical
equation for the line is used to estimate the dependent variable for any given set of values
contained in the independent variables.

Note: Regress does not work with maps containing categorical information, such as a soil
classification map.

Regress <dependentMap>

With <independentMap>
If using more than one independent map, select as needed from the
drop-down list. Click Add after each selection.

Add Click to add the independent map to the command line.

Del Click to delete a highlighted independent map from the command line.

To <newTextFile>

For <newMap>
The resulting map contains predicted values for the dependent map
using the regression equation.
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RelateRelateRelateRelate

Relate is used to quantify the similarity of a map to an evaluation data pattern, or set of
comparison values. A map of similarity is generated that contains values from 0 (least
similar data pattern) to 100 (identical data pattern). At each location, Relate identifies the
values on all specified maps and compares them to the evaluation data set. For example, if a
location has values of 98, 96 and 97 for three map layers it will be identified as very similar
to an evaluation data pattern of 95, 95 and 95. In contrast, a location that has values of 15,
12 and 17 will be assigned a much lower similarity value.

Similarity results are best when all map layers exhibit interval or ratio data types (e.g., 30%
silt, 60% silt, etc.) where the data range forms a bounded linear gradient. Unpredictable
results occur if the values within a data map are categorical (that is, the numbers are
identifiers with no numerical value), such as soil type #1, #2, etc. Numbers exhibiting an
ordinal relationship may be used, such as 1 = best soil, through n = worst soil.

Relate

Map <existingMap>

Weight default = 1
(A weighting factor of 2 means the map will be considered twice
as important.)

Comparison Val

With

Map <anotherMap>

Weight default = 1
(A weighting factor of 2 means the map will be considered twice
as important.)

Comparison Val

Add Click after entering values to add the set to the command line.
Repeat as needed.

Del Highlight a set, then click to remove it from the command line.

For <newMap>
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 Data Conversion Tools

Data conversion tools include Import, Export, and Describe.

ImportImportImportImport

Import creates a new map from a gridded data file in bare, ESRI grid, Surfer grid, or
MapInfo graphic format. The maximum line length in an imported file is 4095 characters.
Line breaks in the import file are ignored; MapCalc imports data to fill the number of rows in
the grid, without regard for line breaks in the import file.

Example: IMPORT FROM Cover.grd Surfer FOR Covermap

Import <existingMap>

Select Format

Bare Bare ASCII matrix of values, row major order.

Grid Grid ASCII format (ESRI)

Surfer Surfer ASCII format (Golden Software)

MIG MapInfo graphic format (MapCalc Professional)

Map Name <mapName identified in the inputFile>

Null Value <nullValue used in the inputFile> Selections include PMAP_NULL,
which equals 3.4E38 (the value that MapCalc uses to represent no
data) and SURFER_NULL, which equals 1.70141E38 (the value that
Surfer uses to represent no data). Any other number can be entered.

Origin If checked, the origin is in the lower left corner, as in a Cartesian grid.

If not checked, the origin is in the upper left corner, as in a matrix.

For <newMap>
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ExportExportExportExport

Export generates a data file of map values in a variety of formats for data transfer.

Example: EXPORT Covertype TO Cover.grd Surfer

Export <existingMap>

Export Map Name <mapName identified in newTextFile>

Select Format

Point X, Y, longitude/latitude, other point values.

Grid Grid ASCII format (ESRI)

Bare Bare ASCII matrix of values, row major order.

Surfer Surfer ASCII format (Golden Software)

MIG MapInfo graphic format (MapCalc Professional)
MIG files are exported with a default 3-color theme
ranging from red (minimum) to green (maximum)

With Commas Uses comma separated variable format.

Origin If checked, the origin is in the lower left corner, as in a
Cartesian grid.

If not checked, the origin is in the upper left corner, as in
a matrix.

Null Value <nullValue> The value entered will not be written to the
exported data file.

Columns/Output Line Number of columns output to one line in exported file.

To <newTextFile>
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DescribeDescribeDescribeDescribe

Describe provides information on map number, map scale, and map status. Describe also
reports information about each map category, including value, label, number of cells and
percent of total map area. The output is written to a text file.

Example: DESCRIBE Covertype

Describe <existingMap>

To <newTextFile>
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Tutorial Macro Tools

Tutorial macro tools include Help Topic, Pause, Note, and Remove.

Help TopicHelp TopicHelp TopicHelp Topic

You can use the macro tools to create map analysis tutorials in MapCalc.

Select a help topic to appear at this step when your tutorial runs.

For instance, if you have just inserted a command to run the Drain analysis tool, then
you can select the Drain online help topic to appear on screen when that command runs.

PausePausePausePause

You can use the macro tools to create map analysis tutorials in MapCalc.

Click this menu command when you want to insert a pause in your tutorial, between
macro commands. When the macro is executed, for instance when a student is observing
the tutorial you created, the program will pause and wait for the student to click a
“Continue” command.

The Pause command gives a student time to observe what is happening in the tutorial,
for instance, to examine a new map that has just been generated by running a map
analysis tool.

NoteNoteNoteNote

You can use the macro tools to create map analysis tutorials in MapCalc.

The Note command opens a text entry box you can use to store a note. The note will
appear on screen when the tutorial runs, at the step where it is inserted when you create
the macro. The student viewing the tutorial may close the note window and continue.

RemoveRemoveRemoveRemove

You can use the macro tools to create map analysis tutorials in MapCalc.

The Remove command enables you to specify that at this step in your tutorial, selected
maps will be closed and removed from the map set. This is helpful when you have
generated many windows with map analysis commands.

To select more than one map, hold the Ctrl key down while selecting the maps in the list.
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10.10.10.10. A Brief Overview of Interpolation

The following was adapted with author's permission from "The Precision Farming Primer" by Dr.
Joseph K. Berry, the complete and unedited version of which is provided on the MapCalc CD.

What is Spatial Interpolation?

Spatial interpolation refers to the generation of a continuous map surface from point
samples. All spatial interpolation techniques establish a "roving window" that:

1 moves to a location in a field

2 calculates an estimate based on the point samples around it

3 assigns the estimate to the center of the window

4 moves to the next location

The extent of the window (both size and shape) affects the result, regardless of the summary
technique. In general, a large window capturing a bunch of values tends to "smooth" the
data. A smaller window tends to result in a "rougher" surface with abrupt transitions.

Three factors affect the window's extent:

• its reach

• the number of samples

• balancing

The reach, or search radius, sets a limit on how far the computer will go in collecting data
values. The number of samples establishes how many data values should be used. If there
are more than enough values within a specified reach, the computer uses just the closest
ones. If there aren't enough values, it uses all that it can find within the reach. Balancing
attempts to eliminate directional bias by ensuring that the values are selected in all
directions around window's center. Once a window is established, the summary technique
comes into play.

What is Inverse Distance Weighting?

Inverse distance weighting (IDW) is an easy interpolation method to conceptualize. It
estimates the value for a location as an average of the data values within its vicinity. The
average is weighted in a manner that decreases the influence of the surrounding sample
values as the distance increases. In an inverse distance squared interpolation, the estimate
is the "inverse distance-squared (1/d²) weighted average" of the samples in the window. The
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closest sample influences the average a great deal more than the farthest sample. Because
this is a static averaging method, the estimated values can never exceed the range of values
in the original field data. Also, inverse distance tends to "pull down" peaks and "pull up"
valleys in the data. The technique is best suited for data sets with random samples that are
relatively independent of their surrounding locations (i.e., minimal regional trend). A surface
generated by the inverse distance technique is sensitive to sampled locations and tends to
put "bumps" around the sampled areas.

What is Kriging?

The inverse distance interpolation technique is fairly straight forward: it is a distance-
weighted average of nearby sample points. Kriging gives us another spatial interpolation tool
to explore before we can consider which is the best technique to determine residual analysis.

Obliquely speaking, the kriging interpolation technique uses "regional variable theory based
on an underlying linear variogram." Without immersion into its theory, it is enough to know
that there is a lot of math behind the technique. In effect, it develops a custom window based
on the spacing and directional trends it detects in the sample data. The reach, or size of the
window, is determined by intersample correlation. The summary technique weights the data
values, aligning them along the trend's direction more than values opposing the trend. This
trend-weighted moving average can result in estimated values that exceed the actual range
of the sampled data. Also, there can be unexpected results in large areas without data
values. The technique is most appropriate for systematically sampled data exhibiting
discernible trends. In general, the kriged surface may be somewhat smoother than the
inverse distance plot.

Above: Comparison of IDW and kriged surface.

By now, you are likely to concede that spatial interpolation is a bit overwhelming. Different
techniques result in radically different renderings for the same set of data. Which rendering
is best?
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How Should An Interpolation Method
Be Chosen?

The only thing certain is that there isn’t a single best method that covers all situations. Some
rules of thumb and general considerations have been discussed, but the only good way to
determine the "best" map is to empirically verify the results. This involves generating several
maps then testing the results against known measurements, aptly termed a test set.
Residual analysis summarizes the differences between map estimates and actual
measurements.

Above: A test set containing 16 random samples (#17-32). Residual
analysis table for average, IDW, and kriging estimates.

In the figure, the "Actual" column lists the measured values for the test locations identified
by the "Col," "Row" coordinates. The difference between these values and those predicted by
various interpolation techniques form the residuals shown in parentheses. The "Average"
column compares the whole field arithmetic mean of 23 (guess 23 everywhere) for each test
location. For example, the first sample (#17) guesses 23 but was actually 0; therefore, it’s off
by 23. Note the sign of the residual indicates whether the guesses are too high (positive) or
too low (negative). If it were a perfect data world, you would expect the "Sum of the
Residuals" to be 0 (just as many high as low misses, in other words, balanced). However, in
this case there is a net residual of -17 (indicating a bias to underestimate). The "Average
Unsigned Residual" is simply the average magnitude of mistakes, regardless whether more
or less than. For the "Average," expect errors of about 22.8 each time you guess. The
"Normalized Residual Index" is simply the ratio of the "Average Unsigned Residual" to the
"Test Set Average." An index of.81 indicates that the "Average" technique isn’t very good.

Now take a look at the residual analysis for the other techniques. Both techniques are
considerably better than the whole field average (indices of.18 and.12, compared to a
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whopping.81), with the kriging technique best, having a 3.3 "Average Unsigned Residual"
and a tendency to underestimate (a "Sum of the Residuals" of -28). The inverse distance
technique is a close second with an index of.18 and a nearly identical underestimate bias
(-29). The asterisks identify test measurements outside the set of samples used for
interpolation.

Is there a significant difference between the various techniques in their estimates for the two
different populations? Would the conclusions change if the test and interpolation samples are
swapped and another residual analysis performed? What if different sampling designs were
tried? What would be the effect of different interpolation parameters (window reach, number
of samples, and data balancing)? Residual analysis gives us a place to start looking for
answers.

To summarize, we have developed a procedure for checking the reliability of an interpolated
map. It suggests holding back some of the field samples to "empirically verify" the estimated
values at the sampled locations. If you don’t, then you are simply accepting the map as
perfect. The difference between an interpolated "guess" (prediction) and "what is"
(measurement) is a residual. A table of all the residuals for a test set is analyzed to
determine the overall accuracy of an interpolated map. The residual analysis determines
that the kriging interpolation procedure has the closest predictions to the test set
measurements. Its predictions, on average, are only 3.3 units off, while the other techniques
were considerably more. The residual table identifies the best interpolated map and just how
good it is, but it fails to identify where in the field the map is likely predicting too high or too
low. That’s the role of an error map (for more information, see "A Map of Error" in The
Precision Farming Primer on the MapCalc CD).

When Is Interpolation Useful?

The reliability of any map based on point data depends on:

• the existence of spatial dependency within the data

• the sampling design employed

• the interpolation algorithm applied

So far we have discussed sampling designs and interpolation algorithms. Now it’s time to
turn our attention to the general concept of spatial dependency.

Spatial dependency within a data set simply means that "what happens at one location
depends on what is happening around it" (formally termed positive spatial autocorrelation).
This simple concept is the foundation for all spatial interpolation.

One approach to determining spatial dependency is the variogram, also called a
semivariogram, which plots the similarity among locations as a function of the distance
between sample points. If the variogram indicates there is a high degree of similarity among
neighboring point samples, then you can generate maps from the data; if there isn’t much
similarity, then you are wasting your time. A pretty map can be generated regardless of the
degree of spatial dependency, but if dependency is minimal, the map is just colorful
gibberish.
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What Is Important About Variograms?

The basic concept of spatial statistics involves spatial autocorrelation, referring to the degree
of similarity among neighboring points (e.g., soil nutrient samples). If they exhibit a lot
similarity, or spatial dependence, they ought to derive a good map. If they are spatially
independent, then expect a map of pure, dense gibberish. How can we measure whether
"what happens at one location depends on what is happening around it?"

Above: Variograms displaying significant spatial dependence (left) and
insignificant spatial dependence (right).

A variogram, or semivariogram, is a plot of the similarity among pairs of values based on the
distance between them. Instead of simply testing whether close things are related, it shows
how the degree of dependency relates to varying distances between locations.

As the distance between points increases, subsets of the data are scrutinized for their
dependency. The spatial dependency among points deteriorates with distance. The range is
the distance at which the sill, or plateau, occurs. It identifies the distance beyond which the
data values are considered to be independent of one another. This tells us that using data
values beyond this distance for interpolation actually can mess up the interpolation. The
value at the Y-axis intercept, or nugget, is a measure of potential data collection error.
Therefore, a variogram that intersects the origin implies that two samples taken at a single
location would have no variation, which is an unlikely scenario in the real world.

If the variogram is generally horizontal, there is insufficient spatial dependency in the data
set to warrant interpolation. If you proceed with the interpolation, a nifty colorful map will
be generated, but it’ll be worthless.
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11.11.11.11. Glossary

For an online reference of mathematical terms, try Eric Weisstein’s World of
Mathematics1: http://mathworld.wolfram.com/

Affine Transformation

Images are typically offset by some amount from the plane of the reference map. Affine
transformation is the mathematical method MapCalc uses to fit raster images to maps. It
is analogous to having the image printed on a rubber sheet that can be stretched in
various directions to force it to conform (geometrically align) to the plane of the reference
map. Once the image has been corrected, its values (for example, blue, green, red, or NIR
reflected energy) can be used in MapCalc processing because all of the numbers in the
stack of maps align.

Coefficient of Variation

Coefficient of variation is a normalized measure of how widely values are dispersed from
the average value. It is computed by dividing the standard deviation by the mean and
multiplying by 100 to express as a percent.

Continuous Data

A data type defined by a set of individual points describing the same parameter, such as
nitrogen sample results in soil, which MapCalc interpolates across a grid to produce a
continuous surface.

Discrete Data

A data type defined by independent, categorical values such as Sand, Clay, or other soil
types. This data type is not interpolated across a grid. MapCalc assigns the value to all
grid squares that contain it.

Inverse Distance

The inverse distance weighting (IDW) method of interpolating data involves calculating
the value of each cell as a distance-weighted average of surrounding data points.

For example, in an inverse square interpolation, the weighting factor is 1/x². Therefore, a
data value that is 2 distance units from the location influences the determined value by
1/4, and a data value that is 4 distance units from the location influences the determined
value by 1/16.

Note that a large search radius or high number of points used in the calculation may not
be the best choice for large data sets, since the effect is a smoothing of the data.

                                                     

1 Not affiliated with Red Hen Systems, Inc.
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Kriging

Kriging is an interpolation method that involves a weighted moving average calculation
of data values between observed points, in which the weighting factors are derived from
variograms (also called semivariograms).

The variogram is fitted to one of several mathematical models; in MapCalc the available
models are spherical, Gaussian, or exponential. The fitted variogram is then used to
interpolate the values across the grid by ordinary kriging.

Kurtosis

Kurtosis characterizes the relative peakedness or flatness of a distribution compared
with the normal distribution. Positive kurtosis indicates a relatively peaked distribution.
Negative kurtosis indicates a relatively flat distribution.

Layer

Data that has been interpolated to a grid, also called a map.

Map

The 2D or 3D display of a data set, also called a layer. Data values in the map are
distributed across a X, Y coordinate grid.

Map Set

A collection of maps, or data layers, interpolated to a common grid.

Mean

Also called arithmetic mean, or average. The mean is an estimate of the central tendency
(typical value) for normally distributed data.

Median

Middle value of a distribution (if sample size is odd) or average of two middle values.

Skew

Skew characterizes the degree of asymmetry of a distribution around its mean.

Positive skew indicates a distribution with an asymmetric tail extending toward more
positive values. Negative skew indicates a distribution with an asymmetric tail
extending toward more negative values.

Standard Deviation

The standard deviation identifies the data intervals above and below the mean that
capture two thirds of the data.

Variance

The variance is an estimate of the data dispersion about the mean for normally
distributed data. Variance is the square of the standard deviation.
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Variogram

A variogram, also called a semivariogram, is a graph of average variance of differences
between pairs of points within specified intervals vs. distance. It provides an idea of the
average difference between any pair of data values separated by some distance. When a
data set is spatially autocorrelated (or spatially dependent), the variogram of the data
displays a positive slope over some distance. At a distance known as the range, the data
points are so far apart that they no longer exhibit a spatial correlation; beyond this
range, the variogram levels off into what is known as the sill.

In practical terms, generating variograms during the map creation process lets you
inspect the data for spatial correlation. It is important to use spatially Note that a few
widely scattered data points over an area are less likely to exhibit spatial correlation
than many data points distributed over the same area. A spatially non-correlated data
set will have a generally horizontal variogram.

WGS84

This is the geographic projection, or datum, that GPS data in which GPS data must be
recorded for compatibility with MapCalc Learner and MapCalc Learner – Academic.
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